The following forum(s) have migrated to Microsoft Q&A (Preview): Azure Virtual Machines!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
Unable to remove the Virtual Network (Classic) after migration. RRS feed

  • Question

  • The following error occurred when try to remove the  Virtual Network (Classic).

    Remove-AzureRmResource : The pipeline has been stopped.
    At line:1 char:1
    + Remove-AzureRmResource -ResourceId "/subscriptions/045620
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : CloseError: (:) [Remove-AzureRmResource], PipelineStoppedException
        + FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.RemoveAzureResourceCmdlet

    DEBUG: 8:14:35 PM - RemoveAzureResourceCmdlet end processing.
    DEBUG: 8:14:35 PM - RemoveAzureResourceCmdlet end processing.
    Remove-AzureRmResource : OperationFailed : The operation '14720b' failed: 'Virtual networks have been migrated already OR in the process of being migrated and hence cannot be changed. In-Migration virtual
    networks []. Migrated virtual networks [Vnet].'.
    At line:1 char:1
    + Remove-AzureRmResource -ResourceId "/subscriptions/0456203...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : CloseError: (:) [Remove-AzureRmResource], ErrorResponseMessageException
        + FullyQualifiedErrorId : OperationFailed,Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.RemoveAzureResourceCmdlet

    How can I remove it? It fails with -Force option.

    I appreciate for your comments.

    Sunday, November 17, 2019 11:31 AM

All replies

  • Hi,

    It looks like there is a separate background task running to migrate this?  Has that gone through?  If you open the Azure portal and select the vNet, there may be something under the 'Activity Log' blade for the vNet to show activity?

    Thanks,

    Matt

    Sunday, November 17, 2019 6:43 PM
  • Hi,

    Migration will take some time.  Please describe the resource in powershell or look at in portal to verify if those resources migrated or not.

    Let me know if that resource is still not migrated.

    As Matt suggested, look at the activity logs as well.

    Monday, November 18, 2019 9:16 AM
  • Hello,

    Any update on the issue?

    If the suggested response helped you resolve your issue, do click on "Mark as Answer" and "Up-Vote" on the answer that helped you for benefit of community.

    Thanks.

    Tuesday, November 26, 2019 10:44 AM
  • Hello,

    Any update on the issue?

    If the suggested response helped you resolve your issue, do click on "Mark as Answer" and "Up-Vote" for the answer that helped you for benefit of the community.

    Thanks.
    Friday, November 29, 2019 10:00 AM