none
visual studio 2010 : “ConfigurationGeneral” rule is missing from the project? RRS feed

  • Question

  • I want to compile a 64-bit application using Visual C++ 2010 professional, but I keep getting this error, and I have no idea what to do :

    1>------ Build started: Project: Test, Configuration: Debug x64 ------
    1>Error: The "ConfigurationGeneral" rule is missing from the project.

    I've searched this problem on google, but all ideas didn't solve my problem.

    Thank you!

    I have windows 8.1 Pro 64bits if this information is needed, and I use visual studio 2010 c++ professional.

    None of my previous applications works, so tried repairing visual studio professional, but it still doesn't work :\

    Wednesday, January 15, 2014 3:22 AM

Answers

  • Hi,

    Please create a new project, say win32 console application, and do the configuration for X64 as following to see whether it works.

    1.          In Configuration manager, click Active solution platform drop down list box, and click new to open New Solution Platform dialog.
    2.          Choose the type of new platform as X64 and click OK.
    3.          Double check the active solution platform and Platform section of project are both x64 and click close.
    4.          Build the X64 solution.

    Reference: How to: Configure Visual C++ Projects to Target 64-Bit Platforms

    If a new and simple C++ project also can get such error, please reinstall VS2010.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, January 15, 2014 9:02 AM
    Moderator