none
net frame work RRS feed

  • Question

  •  do you need to have all versions of dot net frame work installed or can yuo delete all but newest versions i need more disc space and i have all versions from 1 thur to 3.5
    Friday, June 21, 2013 3:31 PM

Answers

  • The .NET Framework versions you need are determined by two factors:

    1. The version requirements of the programs you have installed. Most programs that require .NET Framework support are written to us a specific .NET version, so just having the latest .NET Framework is typically not sufficient. If you want to know which .NET Framework version is required by a program you have, you will have to contact the publisher of that particular program.

    2. .NET Framework version interdependencies. In the case of .NET Framework 2.0/3.0/3.5, these are actually all one framework. 2.0 is the base, full, framework. 3.0 and 3.5 are extensions to 2.0 and cannot be installed unless 2.0 is there first. So, you cannot remove 2.0 and keep 3.0 or 3.5.

    Remembering that removing a .NET Framework from your system will cause all programs needing it to stop working, my advice is to leave them alone.

    Friday, June 21, 2013 6:35 PM