none
I can't install .NET Framework 3.5 onto Windows XP SP2 RRS feed

  • Question

  • Hello,

    I've tried several times today to get the .NET Framework installed onto my computer.

    I've tried 3.0 and 3.5

    I got this in the log:

    [04/30/08,16:21:49] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [04/30/08,16:21:49] WIC Installer: [2] Setup Failed on component WIC Installer
    [04/30/08,16:22:19] WapUI: [2] DepCheck indicates WIC Installer is not installed.

    I also tried to install the WIC installer separately after doing some searching through these forums, but this doesn't load in either. Any thoughts would be appreciated. I unloaded version 2.0 of the .NET and tried again, but no joy. I can't unload the version 1.1 Hotfix, and the 2.0SP1 re-loaded again without any problems once I shut down SPYBOT. However it didn't make any difference with 3.0, or the WIC installer.

    I've tried to find the error log for the WIC installer as well, but I can't seem to find it. Any idea where that might be?

    Any help would be appreciated.
    Wednesday, April 30, 2008 3:40 PM

All replies

  • Hi

     

    Have you tried installing the Framework bits after disabling your virus scanner? The installation of .NET Framework on XP seems to fail when a virus scanner is enabled.

     

    There is a related thread that you can refer to http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2601351&SiteID=1.

     

    HTH

    Thursday, May 1, 2008 12:56 AM
    Moderator
  • Hello,

    Thanks for the reply, but no joy I'm afraid. It's strange. I can install the .NET Framework on other computers here, but not my own.

    The same error keeps coming up.


    Thursday, May 1, 2008 1:05 PM
  •  

    You could try using the Updated .NET Framework cleanup tool: http://blogs.msdn.com/astebner/archive/2007/12/04/6659905.aspx and running the install again. This hsould mostly take care of your issue.

    Thursday, May 1, 2008 4:43 PM
    Moderator
  • Hello,

    Thanks for your reply. I've tried that already. I uninstalled all of the .NET programs on my computer, and then ran the clean up tool. After that I started to reinstall again. Got as far as Ver2. When I tried Ver3, the errors appeared.


    Thursday, May 1, 2008 4:53 PM
  • WIC comes with XP SP3, so I am guessing that your OS has been upgraded to SP3. Can you please check for this and revert to SP2 and then try the install?

    Thursday, May 1, 2008 6:27 PM
    Moderator
  • Hi,

    I'm running on SP2. I wasn't aware that there was an XP SP3. Should I upgrade? I don't think that this is the problem, as all other computers are also on SP2.

    Thanks for the suggestion though
    Thursday, May 1, 2008 6:40 PM
  • Yes, there is an XP SP3 available now. What I meant to say is that WIC (Windows Imaging Component) ships with XP SP3 so I am guessing that you must have unknowingly upgraded to SP3 and this is what might have screwed your .NET install.

    Thursday, May 1, 2008 6:47 PM
    Moderator
  • I just right-clicked "My Computer" and it is telling me that I'm still on SP2.
    Thursday, May 1, 2008 6:52 PM
  • Can you check under "Add Remove Programs" and uninstall WIC or XP3 or both and then try this?

    Thursday, May 1, 2008 9:40 PM
    Moderator
  • Hi,

    I had a look in the "Add/Remove" but I don't see either XP SP3, or WIC

    Is the WIC the Windows Installer Clean-Up? It seems to be smaller that the WIC file that I got from the Microsoft website.

    I tried to install that, but it fails as well.

    Thanks for the reply though.
    Friday, May 2, 2008 2:03 PM
  • Try This...

    Run the command prompt in administrator mode and do the commands

    Dism /online /enable-feature /featurename:NetFx3 /All /Source:X:\sources\sxs /LimitAccess

    here "X" is your CD/DVD drive.

    and wait for the confirmation!

    Monday, July 9, 2012 7:15 AM