locked
Write Code menu option is no longer working RRS feed

  • Question

  • Hi,

    Im using VS2012 update 3 Lightswitch HTML version.

    When writing js code for the HTML client screen or Application data (by clicking on the 'Write Code' menu  on the toolbar above the designer), the code pane is now no longer presented. I'm at a loss why this has stopped working.

    Has anyone else has had this issue?

    Thanks

    Ken
    Thursday, August 15, 2013 2:07 PM

Answers

All replies

  • Hi,

    Please try to uninstall the VS Async CTP SP1 Refresh.

    For more information, please try to refer to those similar thread:
    #Edit Method/Write Code no longer works after applying updates:
    http://social.msdn.microsoft.com/Forums/en-US/cf0b1cd3-9a37-4413-b225-8ff7a34f5037/edit-methodwrite-code-no-longer-works-after-applying-updates .

    http://social.msdn.microsoft.com/Forums/en-US/a53e0887-9f2a-43f0-a1b6-32666a4cde50/lightswitch-c-project-computed-property-edit-method-no-code-window-shown .

    Best Regards,
    Amy Peng


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, August 16, 2013 7:29 AM
    Moderator
  • I had the same problem and after some research found the solution that worked for me.

    Problem: The Write Code\Created method\button under the HTML Client view when looking at the data table would not do anything. I have seen several posts talking about the CTP Async being a problem but since I did not have it my fix ended up being something else. I just spend the last 3 hours on this issue....

    1. First check if you have the folder UserCode under the [application].HTMLClient folder. If you do not have it then create one.

    2. From VS Solution Explorer show all files.

    3. You should see you user folder now, right click the folder and select "include in project"

    4. try again.

    At least this worked for me.


    • Edited by Ronfla Thursday, January 9, 2014 9:37 PM
    Thursday, January 9, 2014 9:36 PM
  • Update to this: This problem only surfaced when I added the code to TFS. The whole project can be checked out but for some odd reason when you first try and use the "create" it may need to create a new java script file and in that process communicate with TFS, this failed and caused the folder to be removed from the project (not file system)
    Wednesday, January 15, 2014 2:53 PM