locked
deploy feature Event receiver with webserivce RRS feed

Answers

  • WSS 3.0 came to the market piror to WCF.

    You can use Feature.xml along with Module.xml during deployment. The Module.xml file contains information about the page or pages that are part of the solution.
    You can reference: Create and Use a SharePoint Feature Package(http://msdn.microsoft.com/en-us/library/ms772130.aspx)

    However, web services should be deployed at _vt_bin, which is contrary to the location of feature.

    You solution should be separate deployment.
    Deploy WCF first and Feature later.
    Cogito ergo sum.
    • Marked as answer by Chengyi Wu Friday, December 18, 2009 2:11 AM
    Tuesday, December 15, 2009 1:17 AM
  • Hi,

    I to agree with this it will work if your Web Service is at one location.
    If this is not the case then if you deploy the WSP on production server but there is no connection between Production server and your Server where you hosted the Web service then your event handler will not work.
    So for this i am suggesting for this.

    If your web service has fixed url then there is no need for all those thing.
    Thanks Shrivallabh Kulkarni MCTS
    • Marked as answer by Chengyi Wu Friday, December 18, 2009 2:11 AM
    Tuesday, December 15, 2009 1:23 PM

All replies

  • any help ?
    Sunday, December 13, 2009 8:35 AM
  • Hi,

    I dont think there is any tool which will deploy the evet handler as well as your web service.
    Beacause both the things are different means one will deploy on Sharepoint site and another on IIS.

    So i think you have to perform both the operation separatly.
    Thanks Shrivallabh Kulkarni MCTS
    Sunday, December 13, 2009 10:54 AM
  • what do you mean by separatly ?
    do you mean that do the deployment process as usual for the event by creating wsp project.
    and where should I go with the app.config file for the webserivce ? how do sharepoint know that my feature gonna use a webserice ?
    Sunday, December 13, 2009 10:58 AM
  • Ya good Question, :)

    As you make  use of service by visual studio add as reference there is the Problem beacause when you do in that way then your Web Service url will get fixed. 

    So Solution is Proxy Creation for your Current Web Service. I put following suggestion on another post for using UserGroup.asmx  service.
    So perform following steps.

    Before creating Proxy class you have to publish your service in IIS.
    Proxy is like bridge between your Application and Web Service.


    a. So I suggest to  create the Proxy class of this UserGroup.asmx  by using wsdl command.for this go through this

    http://msdn.microsoft.com/en-us/library/7h3ystb6.aspx

    b. Use this proxy which will connect to the UserGroup.asmx service by passing the Service url as parameter.this might be like this

    public UserGroup(string serviceUri){

    this.Url = serviceUri;

     

    }


    c. Add this class in class library project give snk.

    d. Use this in your application by initializing that proxy object. So you can use every time whenever needed. 

     Hope this will help you.


    Thanks Shrivallabh Kulkarni MCTS
    Sunday, December 13, 2009 11:27 AM
  • I think there should be an easier way to deploy feature with WFC. since microsoft give us the ability to add a service reference to to the feature project, then there should be another way to do that ?!

    Monday, December 14, 2009 7:48 AM
  • Even if you got some way to deploy the Web Service along with Feature. But the at that time your Service url will get be changed due to this it will not find the new Web Service url for your feature.
    Thanks Shrivallabh Kulkarni MCTS
    Monday, December 14, 2009 9:08 AM
  • WSS 3.0 came to the market piror to WCF.

    You can use Feature.xml along with Module.xml during deployment. The Module.xml file contains information about the page or pages that are part of the solution.
    You can reference: Create and Use a SharePoint Feature Package(http://msdn.microsoft.com/en-us/library/ms772130.aspx)

    However, web services should be deployed at _vt_bin, which is contrary to the location of feature.

    You solution should be separate deployment.
    Deploy WCF first and Feature later.
    Cogito ergo sum.
    • Marked as answer by Chengyi Wu Friday, December 18, 2009 2:11 AM
    Tuesday, December 15, 2009 1:17 AM
  • Hi,

    What you are using WCF service or Web Service?

    If you are using WCF service then there will svcutil is the command to generate the proxy.
    The for this class it will connect to WCF at runtime.

    As Chengyi suggested you have to deploy WCF first and Feature later.
    But only thing if your WCF service server will down or you created another WCF service then your feature will not work.

    So to solve such like issue i am suggesting you to use this proxy class.
    The Service url you will put in Web.config of WebApplication. In feature this proxy class you will connect to this service url.

    Hope this will help you.
    Thanks Shrivallabh Kulkarni MCTS
    Tuesday, December 15, 2009 5:21 AM
  • do you have any samples or links about such cases ? WCF with Feature ? how to deploy WFC with Sharepoint ?

    I am using webservice
    Tuesday, December 15, 2009 8:41 AM
  • Well, I followed the regualre package way "wsp" and it worked !!! I did not depoy any thing related to the Webservice and wsp take care of that !
    so the answer, actually you do not need to do any thing, just let the packag do its works

    Tuesday, December 15, 2009 1:14 PM
  • Hi,

    I to agree with this it will work if your Web Service is at one location.
    If this is not the case then if you deploy the WSP on production server but there is no connection between Production server and your Server where you hosted the Web service then your event handler will not work.
    So for this i am suggesting for this.

    If your web service has fixed url then there is no need for all those thing.
    Thanks Shrivallabh Kulkarni MCTS
    • Marked as answer by Chengyi Wu Friday, December 18, 2009 2:11 AM
    Tuesday, December 15, 2009 1:23 PM