none
AS2 EDI -- Http 500 error RRS feed

  • Question

  • Hello,

    I have a vendor who sends us 894 edi's via AS2 through our Virtual directory and in return we are sending reponse 500 instead of 200. We have at our end receivelocation as 2 way --AS2EDIReceive and AS2Send . I have tried to search for this error and no help. Even we do the same way with other vendor and for just testing we send them another vendor's Virtual directory path and it worked fine the logs on IIS was 200  but as soon as they switch back to orginal VD we send them 500 response.

    I recreated the Virtual directory again with the same options as another vendor, still same issue. PLEASE HELP.

    • Moved by Ben Cline1Moderator Friday, November 19, 2010 1:28 PM Related to EDI and AS2 (From:BizTalk Server General)
    Thursday, November 18, 2010 11:42 PM

Answers

  • I recreated the receive location with the new VD Path and made it sure "Use Single Sign-on " is unchecked. and it worked fine
    • Marked as answer by Soneta Friday, November 19, 2010 9:42 PM
    Friday, November 19, 2010 9:41 PM

All replies

  • Hi 
    Error 500 is "internal server error" which returns IIS
    I am siggesting that you have a bug in that VD which responses with 500

    check event log on host server for details.

    And 200 code is returned when a code was executed without errors

    Please mark this as answer if it helps.
    Microsoft Certified Trainer
    Microsoft Certified Professional Developer
    BizTalk blog: http://biztalk.kirakosyan.com
    Friday, November 19, 2010 7:49 AM
  • Additionally you can enable IIS tracing. Read this article about how to see more information in IIS: http://msdn.microsoft.com/en-us/library/wwh16c6c.aspx
    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://pi.hauth.me

    Friday, November 19, 2010 8:10 AM
  • There is no logs in the event logger as why it failed. I will try to see IIS tracing.
    Friday, November 19, 2010 1:21 PM
  • I recreated the receive location with the new VD Path and made it sure "Use Single Sign-on " is unchecked. and it worked fine
    • Marked as answer by Soneta Friday, November 19, 2010 9:42 PM
    Friday, November 19, 2010 9:41 PM