locked
Publishing error - 'Could not find a webserver' RRS feed

  • Question

  • I have attempted to publish my site to the webserver and after approx three seconds I receive the following dialogue box message:

    'Could not find a webserver at hosting2.123-reg.co.uk on port 21. Please check to make sure that the web server name is valid and your proxy settings are set correctly or the webserver maybe temporarily out of service.

    I have entered the correct server info, password etc.
    I tried ten times over two days and also turned of my firewall and anti-virus software before trying again.
    In the end I used another FTP software and uploaded everything fine and the website site is live and working fine.
    However, I would prefer to manage the site using EW and want to know how to fix this issue.

    Any ideas anyone?
    Tuesday, July 1, 2008 3:47 PM

Answers

  • Anna Ullrich said:

    q3pd said:

    I have attempted to publish my site to the webserver and after approx three seconds I receive the following dialogue box message:

    'Could not find a webserver at hosting2.123-reg.co.uk on port 21. Please check to make sure that the web server name is valid and your proxy settings are set correctly or the webserver maybe temporarily out of service.

    I have entered the correct server info, password etc.
    I tried ten times over two days and also turned of my firewall and anti-virus software before trying again.
    In the end I used another FTP software and uploaded everything fine and the website site is live and working fine.
    However, I would prefer to manage the site using EW and want to know how to fix this issue.

    Any ideas anyone?

    Have you tried changing the Passive FTP setting in Expression Web and then trying to connect with FTP?

    Anna


    http://blogs.msdn.com/anna

    Anna, that may not be the only place that setting needs to be changed. When I installed EW2 and had the same issue described, I had already turned off passive FTP in EW, because one of my clients uses LunarPages. They require active FTP for sites hosted on Windows servers (but not Linux; go figure). I came here looking for a resolution and found a similar message posted just that day. Someone, I believe it was Gregory or Steve, suggested turning off the passive FTP setting in Internet Explorer (Tools|Internet Options|Advanced).

    I did so, shut down and restarted, and was immediately able to connect without a problem. Apparently the tight linkage between IE and EW causes that setting in IE to affect the behavior of EW in this circumstance. In any event, it's worth a try to see if that resolves the issue, and if it does, perhaps this could be added to the FAQs.

    cheers,
    scott


    • Proposed as answer by paladyn Tuesday, August 5, 2008 5:03 AM
    • Marked as answer by Lori DirksModerator Sunday, November 23, 2008 12:20 AM
    Wednesday, July 2, 2008 5:52 AM

All replies

  • I believe as well that there are FTP publishing problems in EW. I have my own dedicated server that I publish to and control. Using EW I have a lot of connection problems, errors, extreme slowness etc etc etc.

    I've tried various FTP/Passive/Firewall settings over and over and over again with no rock solid combination. It usually works but not all the time and always slow. Especially doing a full site publish, it just takes forever to compare files and then publish....and these are generally small web sites.

    Publishing individual files usually go better, but sometimes they "can't find server on port 21" or "500 error of some sort".

    Yet if I open a dedicated FTP client things move quick as can be and doesn't even seem effected by any other system settings - it just works.

    MS, please look into EW FTP publishing. We need more speed and reliability.
    Tuesday, July 1, 2008 4:18 PM
  • q3pd said:

    I have attempted to publish my site to the webserver and after approx three seconds I receive the following dialogue box message:

    'Could not find a webserver at hosting2.123-reg.co.uk on port 21. Please check to make sure that the web server name is valid and your proxy settings are set correctly or the webserver maybe temporarily out of service.

    I have entered the correct server info, password etc.
    I tried ten times over two days and also turned of my firewall and anti-virus software before trying again.
    In the end I used another FTP software and uploaded everything fine and the website site is live and working fine.
    However, I would prefer to manage the site using EW and want to know how to fix this issue.

    Any ideas anyone?

    Have you tried changing the Passive FTP setting in Expression Web and then trying to connect with FTP?

    Anna


    http://blogs.msdn.com/anna
    Tuesday, July 1, 2008 8:48 PM
    Moderator
  • Anna Ullrich said:

    q3pd said:

    I have attempted to publish my site to the webserver and after approx three seconds I receive the following dialogue box message:

    'Could not find a webserver at hosting2.123-reg.co.uk on port 21. Please check to make sure that the web server name is valid and your proxy settings are set correctly or the webserver maybe temporarily out of service.

    I have entered the correct server info, password etc.
    I tried ten times over two days and also turned of my firewall and anti-virus software before trying again.
    In the end I used another FTP software and uploaded everything fine and the website site is live and working fine.
    However, I would prefer to manage the site using EW and want to know how to fix this issue.

    Any ideas anyone?

    Have you tried changing the Passive FTP setting in Expression Web and then trying to connect with FTP?

    Anna


    http://blogs.msdn.com/anna

    Anna, that may not be the only place that setting needs to be changed. When I installed EW2 and had the same issue described, I had already turned off passive FTP in EW, because one of my clients uses LunarPages. They require active FTP for sites hosted on Windows servers (but not Linux; go figure). I came here looking for a resolution and found a similar message posted just that day. Someone, I believe it was Gregory or Steve, suggested turning off the passive FTP setting in Internet Explorer (Tools|Internet Options|Advanced).

    I did so, shut down and restarted, and was immediately able to connect without a problem. Apparently the tight linkage between IE and EW causes that setting in IE to affect the behavior of EW in this circumstance. In any event, it's worth a try to see if that resolves the issue, and if it does, perhaps this could be added to the FAQs.

    cheers,
    scott


    • Proposed as answer by paladyn Tuesday, August 5, 2008 5:03 AM
    • Marked as answer by Lori DirksModerator Sunday, November 23, 2008 12:20 AM
    Wednesday, July 2, 2008 5:52 AM
  • Relating to FTP problems - by turning the Passive FTP setting off I could get connected.

    Thanks!!
    Wednesday, July 2, 2008 8:43 PM
  • Yep, turning off the Passive FTP option in Expression Web and in IE did the trick.  Thanks for the tip!
    Tuesday, August 5, 2008 3:35 AM
  • Wow, changing the passive FTP setting in both Expression Web and IE did it (after restarting).  Thanks!
    Friday, October 31, 2008 9:49 PM
  • This also may be just another Microsoft Bug.  I have the same problem and it is Expression Web 2 that is at fault.  I have FTP software that is set up identical and works just fine.  I have no firewall...  I have two laptops, both running XP PRO, both loaded from the same source, one works, one doesn't.  The port 21 thing is totally bogus in my case, and MS wants $95 to talk to me about their problem.


    Tuesday, June 2, 2009 3:48 PM
  • Obviously if one works and the other does not, they are not set up identically.
    FWIW EW does *Not* have its own ftp engine, it uses the native windows ftp

    FrontPage MVP
    Tuesday, June 2, 2009 4:36 PM
  • I wouldn't worry about it, Steve. It appears that he didn't bother to actually read this eight-month-dead thread he resurrected before posting his rant. The resolution to the issue is clearly stated in the thread, and is repeated in a number of threads easily retrievable using the forum search feature and searching on "port 21."

    cheers,
    scott
    Tuesday, June 2, 2009 6:25 PM
  • Good point.
    I just could not pass on the *they are set up identically and one works and the other does not*


    FrontPage MVP
    Tuesday, June 2, 2009 9:47 PM
  • Well I am late to this party. I have adopted all the instructions and still am getting the port 21 error. I am using Windows 7 and Expression 2.

    I load one website to a server just fine through Expression.

    Another will not go.

    What is up?

    Tuesday, August 3, 2010 9:28 PM
  • You are very late to the party.  Look at the starting date.

    Please start your own thread, with details.

    Tuesday, August 3, 2010 10:27 PM
  • The problem, FisF, is that any remedies noted earlier in the thread were obliously for EW2 on a different OS (given the age of the thread). They don't apply to your problem. At. All.

    That is why it is soooo VERY important to LET DEAD THREADS STAY DEAD! It just confuses things.

    Start your own thread, as it says to do in the "BEFORE POSTING! - Expression Web FAQs - Forum Guidelines - READ BEFORE YOU POST!" thread at the top of this forum.

    Be very specific about what you are doing, settings, error messages, OS version, etc.


    Some see the glass as half full. Others see the glass as half empty. I see a glass that's clearly twice as large as it needs to be.
    Tuesday, August 3, 2010 11:19 PM