none
Data Menu works in WinForms & Class Library but not Web Application Project (VS2008) RRS feed

  • Question

  • Hi, I have installed VS2008 + Team Explorer plus SP1.

    When I do File New Project and create a Windows Form Project or a Class Library project, I have a "Data" menu with Show Data sources (shift+alt+d), and can get to the Data sources pane, create data sources, etc.

    In Web Application Project, I cannot see this menu.  When I use customize to add the menu item, it's disabled.

    This thread seems to be relevant: http://social.msdn.microsoft.com/Forums/en-US/vstsdb/thread/b48c7969-17bf-4626-bcff-0fdfcac62321.

    Should I expect the Data Sources pane to be available in Web Applications project?

    Thanks.

    • Moved by Barclay Hill Friday, July 9, 2010 9:20 PM More appropriate forum (From:Visual Studio Database Development Tools (Formerly "Database Edition Forum"))
    Friday, July 9, 2010 3:38 PM

All replies

  • Hello,

    Yes, there is a Data menu in Web applications, however, items in it are not the same. Please try the following to bring the menu back:

    1. please go to Tools -> Import and Export settings and reset all the settings of Visual Studio
    2. Also, it could be done in command prompt by executing devenv.exe /resetsettings.

    Best regards


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback, please tell us.
    Welcome to the All-In-One Code Framework!
    Wednesday, July 14, 2010 8:02 AM
  • I'm having some kind of different issue.  I see the Data menu periodically, and if I add "Show Data Sources" manually to a toolbar, it's enabled when the web project is first opened.  But when I click "Show Data Sources", it does show the data sources, but after that the toolbar button becomes disabled.

    I have uninstalled SQL Publishing Wizard from Add/Remove programs (not thinking I needed that), and I get this error when I start Server Explorer:

     Package Load Failure

    Package 'Microsoft.SqlServer.Tools.PublishWizard.VSCommands.MenuCommandsPackage, version 1.2.0.0 <etc> has failed to load.'

    Probably related.  I'll research it.

    Thursday, July 15, 2010 1:34 PM
  • First I tried to reinstall SqlPub\SqlPubWiz.msi from WCU in VS2008 Setup Disk; it said I couldn't install it outside of VSSetup.  Then, googling how to reinstall it, I found the VS2008 sp1 readme which had a link to the standalone SQLPub 1.3 installer, so I fixed the Server Explorer problem.

    Here is the behavior:

    1) I don't have the Data Menu on Web Application projects; I do ALWAYS have the menu on Winforms and Class Library projects.

    2) I have manually added "Data|Show Data Sources" to a toolbar.

    3) If I exit and restart VS2008, and open a Web Application Project, the Show Data Sources menu is ENABLED.

    4) If I click it, it shows data sources, and then disables the show data sources toolbar button.

    5) If I start Server Explorer, the show data sources toolbar button is disabled.

    6) I can then open a class library button and the button becomes enabled and works again, but if I go back to a Web Application project, it's disabled.

    7) This behavior persists until I exit and restart VS2008.

    I either have some configuration problem or else it's a bug.  I could probably uninstall vs2008 completely and reinstall it and it would fix it, but for now, it's not really a showstopper, just a interesting dilemma.

    anyone else seeing behavior like this?  or do you always have "show data sources" and data menu in your web application projects?

     

    FYI I also do reset all settings in tools menu.  no change.

    Thursday, July 15, 2010 2:20 PM