none
Error in Install-ContainerHost.ps1 RRS feed

  • Question

  • I'm running "Install-ContainerHost.ps1" on Windows Server 2016 TP5 on Azure. After the restart of the script, I logon to the VM and after a while I get this error:

    Installing ContainerImage provider...

    Getting Container OS image (WindowsServerCore -MinimumVersion 10.0.14300.1000 -MaximumVersion 10.0.14300.1010) from OneGet (this may take a few minutes)...

    WARNING: Based on customer feedback, we are updating the Containers PowerShell module to better align with Docker. Aspart of that some cmdlet and parameter names may change in future releases. To learn more about these changes as wellas to join in the design process or provide usage feedback please refer to http://aka.ms/windowscontainers/powershell

    Container base image install complete.

    Creating a first boot layer...

    An error occurred trying to connect: Post http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/build?buildargs=%7B%7D&cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=dockerfile&labels=%7B%7D&memory=0&memswap=0&rm=1&shmsize=0&t=windowsservercore%3Alatest&ulimits=null: open //./pipe/docker_engine: The system cannot find the file specified.

    Script complete!

    Looking at "C:\ProgramData\docker\daemon.log"

    starting daemon: Error initializing network controller: Error creating default network: HNS failed with error : Failed to create network" 
    time="2016-05-19T14:55:08.720752300Z" level=info msg="Windows default isolation mode: process" 
    time="2016-05-19T14:55:08.723752600Z" level=info msg="[graphdriver] using prior storage driver \"windowsfilter\"" 

    Any ideas?

    Thursday, May 19, 2016 2:56 PM

All replies

  • Having the same error message like you after the docker container worked successfully yesterday, it fails today after TP5 on Azure got some updates (I think).

    Reported an issue: https://github.com/Microsoft/Virtualization-Documentation/issues/273

    Tuesday, May 24, 2016 1:13 PM