locked
Load report failed RRS feed

  • Question

  • User-1140805647 posted

    hi there,

    i am using vs 2008, crystal report 10.5 and oracle 10g.  when i deploy my project on client machine the crystal report gives an error like "Load report failed". I have installed CRRedist2008_x86.msi but still it give error.

    Thanks

    Thursday, June 2, 2011 2:29 AM

Answers

  • User-1140805647 posted

    hi all,

    finally i resolve the problem. this is because the crystal report path is mismatch.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, June 4, 2011 12:24 AM

All replies

  • User-1364446067 posted

    Hi.

    Try following:

    - Delete the temp files from the server

    - Set the Maximum Job limit to -1 (in windows registery)

    - In your code make sure you close and dispose the report document object correctly

    - Restart the server

     

    Also see this: http://www.crystalreporthostingnews.com/index.php/archives/101

    --

    Hope this helps..

    Thursday, June 2, 2011 5:50 AM
  • User-1140805647 posted

    hi,

    thanks for your post.

    i tried it but it won't help me. it still give error

    Thursday, June 2, 2011 6:32 AM
  • User1196771204 posted

    hi niles,

    The "Load Report failed" error message can be caused by several factors:

    1. The crystal report version installed on the server is different with the crystal report version installed on your local PC. This is why sometimes you can experience the fact the CR works locally, but fails on the server
    2. The assemblies used on your web.config on the server is different with the assemblied used on your local PC
    3. The permission to run Crystal Report was not set properly. Please take note that Crystal Report must operate under FULL TRUST setting
    4. The required aspnet_client and crystalreportviewer folders are not copied to your working site
    5. The application pool operates on wrong permission level

    If you can make sure you get all the 5 items above correctly. I GUARANTEE your crystal report will load fine. I have not tried to run Crystal Report over an Oracle database, but I did experience the same error message in the past over the MS SQL database. However, I do believe that the "Load Report Failed" error message does not have any relation with the type of database you use on your backend. It is more on the setting of the Crystal Report itself.

    If you still experience problems, I would suggest you to contact asphostcentral.com, who specialises in Crystal Report hosting. However, they do support MSSQL database only and if you can change your database to MSSQL, you can certainly host your CR project successfully. You can download the SQL 2008 Express FREE of charge from http://www.microsoft.com/express/Database/.

    Good luck! Please mark this post as an "answer" if it helps you.

    :-)

    Thursday, June 2, 2011 10:07 PM
  • User-1364446067 posted

    If your report contains formula fields, then please also check those if they are being evaluated correctly too.

    --

    Hope this helps..

     

    Friday, June 3, 2011 12:22 AM
  • User-1140805647 posted

    hi,

    thanks for post. i will check it out

    Friday, June 3, 2011 12:30 AM
  • User1196771204 posted

    just wondering...

    how do you go about it? Will you be able to resolve the issue?

    Friday, June 3, 2011 11:51 PM
  • User-1140805647 posted

    hi hassanmehmood,

    i chekced out your suggestion but there is no problem in fomula fields.

    thanks

    Friday, June 3, 2011 11:58 PM
  • User-1140805647 posted

    hi necro,

    till i'm not able to resolve the issue

    Friday, June 3, 2011 11:59 PM
  • User-1140805647 posted

    hi all,

    finally i resolve the problem. this is because the crystal report path is mismatch.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, June 4, 2011 12:24 AM