none
No connection could be made because the target machine actively refused it 127.0.0.1:10002

    Question

  • No connection could be made because the target machine actively refused it 127.0.0.1:10002 when run the azure application.
    Thanks and Regards, Sachin Nikam.
    Friday, August 5, 2011 9:32 AM

Answers

All replies

  • Please ensure that development storage service is initialized and running.

    Hope this helps.

    Thanks

    Gaurav Mantri

    Cerebrata Software

    http://www.cerebrata.com

     

    Friday, August 5, 2011 9:43 AM
  • I am new to Azure...How to check  development storage service is initialized and running?



    Thanks and Regards, Sachin Nikam.
    Friday, August 5, 2011 9:58 AM
  • I should have been more explicit about this. To check if development storage service is running, please check DSService.exe under "Processes" tab in task manager. You can start it manually by going into "C:\Program Files\Windows Azure SDK\v1.4\bin\devstore" folder (assuming you have the latest version of Windows Azure SDK installed.

    To initialize development storage service, you will find DSInit.exe application in the same folder. You would need to run that application to initialize your development storage.

    Hope this helps.

    Thanks

    Gaurav

    Friday, August 5, 2011 10:07 AM
  • Hi!

    I found the DSINIT.exe in required folder

    but still it gives following message while installing DSINIT

     

     

    The option is not valid: [/sqlinstance:SW8\SQL2008EX]

    Syntax:

         DSInit [/sqlinstance:<SQL server instance>] [/forceCreate] [/user:<Windows account name>]

     

    Description:     

           Initialize the development store for usage by

              Reserving http ports for the blob, table and queue services for the current user, and

              Creating the database needed by the blob and queue services

    Options:

          sqlinstance : the name of the SQL Server instance on the local machine that should

                        be used for Development Storage. The default is SQLExpress.

                        Use "." for unnamed instance.

          forceCreate : recreate the database even if it already exists.

          user        : user for whom ports are to be reserved. By default it is the current user.

     

     


    Thanks and Regards, Sachin Nikam.
    Friday, August 5, 2011 10:19 AM
  • Hi Sachin,

    Please refer to How to fix Failed to initialize Windows Azure storage emulator error and Run Azure Storage Emulator with a full SQL Server installed. Basically we use the following command line to initialize the Windows Azure storage emulator database:

    dsinit /sqlInstance:. /forceCreate

    "." is the SQL Server instance that installed in your local machine. If the SQL Express is installed when installing Visual Studio, the instance name may be ".\sqlexpress".

    Also you may want to completely resintall the Azure SDK from http://www.microsoft.com/windowsazure/sdk/.

    Thanks.


    Wenchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Marked as answer by Wenchao Zeng Friday, August 12, 2011 8:56 AM
    Monday, August 8, 2011 9:25 AM
  • Hi,

    I will mark the reply as answer. If you find it no help, please feel free to unmark it and follow up.

    Thanks.


    Wenchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Friday, August 12, 2011 8:56 AM