locked
Can't open native C++ project because it targets .NET 4

    Question

  • Right now, I'm running on a machine with very little bandwidth and really can't go downloading .NET 4. I've got a native C++ project created in VC10, but VS vNext won't open it because it, supposedly, targets .NET 4 and I don't have that installed. My project does not include one single scrap of CLR code for any version- it's all native C++.
    Wednesday, September 21, 2011 9:19 PM

Answers

  • Hi DeadMG,

     

    so this is a side effect of opening up a native C++ project in the express edition which is what was installed on the Windows Developer Preview with tools.   I realize this suggestion doesn't help with a machine with little bandwidth but if you want to work with native C++ projects then the best bet is to try to install the Microsoft Visual Studio 11 Developer Preview from

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=27543

     

    much appreciated,

    Mike Wong

    Microsoft Developer Support

    Wednesday, September 21, 2011 10:19 PM
    Moderator

All replies

  • Hi DeadMG,

     

    so this is a side effect of opening up a native C++ project in the express edition which is what was installed on the Windows Developer Preview with tools.   I realize this suggestion doesn't help with a machine with little bandwidth but if you want to work with native C++ projects then the best bet is to try to install the Microsoft Visual Studio 11 Developer Preview from

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=27543

     

    much appreciated,

    Mike Wong

    Microsoft Developer Support

    Wednesday, September 21, 2011 10:19 PM
    Moderator
  • Hi DeadMG,

     

    here is another option if you didn't want to download the Microsoft Visual Studio 11 Developer Preview

    From the following post:

    http://social.msdn.microsoft.com/Forums/en-US/winappswithnativecode/thread/73e8c131-1a2a-41b4-b028-6cefc5ad305f

  • Failure to load existing DLL projects with the dotNet 4.0 message is a bug we know about and will be fixed in future releases. Meanwhile to unblock yourself you could add the following lines in the project (.vcxproj) file itself. In the “globals” property group:

    <TargetFrameworkIdentifier>.NETCore</TargetFrameworkIdentifier>
    < TargetFrameworkVersion>v4.5</TargetFrameworkVersion>

     

    much appreciated,

    mike

Thursday, September 22, 2011 7:52 PM
Moderator