none
Error 400 when changing xla reference RRS feed

  • Question

  • My Excel application provides 2 xla files. One xla file has a reference to the other one.

    Now I'd like to change into new file format xlam. That doesn't work because I'm not able to change the reference.

    Whenever I click on OK at the Reference form (after selecting xlam file) I will get Error 400 and the previous reference is gone.

    How can I change the reference without error?

    TIA

      Reinhard

    Monday, June 15, 2015 3:22 PM

All replies

  • Hi Reinhard,

    >>Whenever I click on OK at the Reference form (after selecting xlam file) I will get Error 400 and the previous reference is gone.<<

    Did you mean that you add ther reference for the add-ins from the Visual Basic Editor-> Tool-> reference?

    If I understood correctly, I add the reference successfull after I rename the second xla file VBA project name since the name by default(VBAProject) conflicts with the Original one. And here is a figure that the new workbook refer to the first XLA add-in(book1.xla) which refer to second XLAM add-in(11.xlam) for your reference:

    If I misunderstood, please feel free to let me know.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 16, 2015 3:09 AM
    Moderator
  • >>Did you mean that you add ther reference for the add-ins from the Visual Basic Editor-> Tool-> reference?

    Yes

    It's amazing, I can't change the reference within a xla(m) to another xla(m).

    If I change it to xlsm then it's possible to set a reference to a xla(m).

    But if the xlsm already has some code it fails again -> strange behavior:-(

    Thanks,

      Reinhard

    Thursday, June 18, 2015 11:33 AM
  • Hi Reinhard,

    I am still not able to reproduce this issue in Excel 2013. Would you mind sharing the details step by step to help us to reproducet this issue? And which version of Excel are you using?

    In addtion, it is appreciate to upload the sample workbook to help us to narrow donw this issue. You can uplaod it via OneDrive and please remove the sensitive data before you uploading.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, June 19, 2015 9:34 AM
    Moderator
  • test1.xla: https://onedrive.live.com/redir?resid=7F6944E967CD7E99!3232&authkey=!AAJjMlRXeUZiK2w&ithint=file%2cxla

    test1.xlam: https://onedrive.live.com/redir?resid=7F6944E967CD7E99!3233&authkey=!AFX7UkpnUXiLSnk&ithint=file%2cxlam

    test2.xlam: https://onedrive.live.com/redir?resid=7F6944E967CD7E99!3234&authkey=!ACNIhbaYFTlWquA&ithint=file%2cxlam

    Excel 2013 (always disable macros)

    1. Open file test2.xlam

    2. VBA-Editor [Tools]-[References}

    3. Untick reference test1

    4. [Browse] to reference file test1.xlam

    -> Error 400 or "Can't add reference to the specified file."

    Thanks,

      Reinhard

    Friday, June 19, 2015 4:22 PM
  • -> Error 400 or "Can't add reference to the specified file."

    I can not reproduce this behavior.

    When I disable the macros and/or disable the AddIns inside the Trust Center, I get always a "MISSING" in front of the reference of "test1". (And the test1.xla AddIn is not loaded.)

    Try to reproduce the behavior in safe mode (close Excel, press the CTRL key and hold it down, open Excel and wait until a message is shown, release the CTRL key, answer the question with Yes).

    If the issue persists, show us some screen shots of the Trust Center: Trusted Locations, Trusted Documents, Add-Ins and Macro Settings

    Andreas.

    Sunday, June 21, 2015 5:34 AM
  • Hi reihard,

    Is the suggestion provide by Andreas helpful?

    In addition, it seems the links provied by above is broken, would you minding check them?

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 23, 2015 3:28 AM
    Moderator