locked
SSRS opens a blank page RRS feed

  • Question

  • Hi,

    I just installed SSRS on my SQL Server 2008 but when I type the link to this in Internet Explorer I get a blank page. What could be causing this?

    Cheers

    Paul

    Thursday, July 4, 2013 3:21 PM

Answers

  • I just removed:

    			<RSWindowsNegotiate/>
    			<RSWindowsNTLM/>
    

    and left <RSWindowsBasic/> and it seems to be working.
    • Marked as answer by Fanny Liu Monday, July 15, 2013 9:20 AM
    Friday, July 5, 2013 2:02 PM

All replies

  • What link are you entering?  You should be entering:

    http://ReportServer/Reports/Pages/Folder.aspx

    Check to make sure that "ReportServer" is the name of your reporting server.  For example, it might be titled "evolvssrs" or some other name.  Also, sometimes there is a database server separate from the reporting server.  You might also try pinging this server to make sure it is alive. Also, try this URL below. 

    http://ReportServer/ReportServer

    Thursday, July 4, 2013 7:50 PM
  • I was trying http://win2008vmserver/reports but I have tried your suggestions with no joy.

    The database is held on the same server.

    Friday, July 5, 2013 8:54 AM
  • Hi Paul,

    Go to Start>MicrosoftSQLServer 2008>Configuration Tool>reporting services configuration Manager

    then connect>Report Manager URL> click on the URL mentioned there

    If it still doesn't show the report server: navigate to below location

    C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer

    Open rsreportserver xml file go to 

    <Authentication>
    <EnableAuthPersistence>true</EnableAuthPersistence>
    <RSWindowsExtendedProtectionLevel>off</RSWindowsExtendedProtectionLevel>
    <RSWindowsExtendedProtectionScenario>proxy</RSWindowsExtendedProtectionScenario>
    </Authentication>

    Add  <AuthenticationTypes>
    <RSWindowsBasic/>
    </AuthenticationTypes> within Authentication tag

    Try to go to same url again. It will prompt you for username & password. Enter your system username and password.

    Refer below url:

    http://msdn.microsoft.com/en-us/library/ms157273.aspx

    Hope this helps

    Avijit

    Friday, July 5, 2013 11:08 AM
  • The report server is shown in Report Manager URL.

    I tried adding <RSWindowsBasic/> to the xml  that but it made no difference. The XML already contained the following:

    <Authentication>
    		<AuthenticationTypes>
    			<RSWindowsNegotiate/>
    			<RSWindowsNTLM/>
    		</AuthenticationTypes>
    		<RSWindowsExtendedProtectionLevel>Off</RSWindowsExtendedProtectionLevel>
    		<RSWindowsExtendedProtectionScenario>Proxy</RSWindowsExtendedProtectionScenario>
    		<EnableAuthPersistence>true</EnableAuthPersistence>
    	</Authentication>

    Friday, July 5, 2013 1:42 PM
  • I just removed:

    			<RSWindowsNegotiate/>
    			<RSWindowsNTLM/>
    

    and left <RSWindowsBasic/> and it seems to be working.
    • Marked as answer by Fanny Liu Monday, July 15, 2013 9:20 AM
    Friday, July 5, 2013 2:02 PM