none
Can't delete a vpn connection, please help RRS feed

  • Question

  • I am trying to delete a VPN connection, which is part of Virtual Network Gateway definition.

    The portal simultaneously shows the connection as "Deleting" and "Not Found" (see the screen shot). 

    An attempt to delete the connection using CLI, either using a local machine or the Azure Cloud Shell, results in an error.

    Command: az network vpn-connection delete --name vpn-connection-staging --resource-group rg-vnet-staging

    Error: 

    Deployment failed. Error occurred in request., SSLError: HTTPSConnectionPool(host='arm-rpfd-prod.trafficmanager.net', port=443): Max retries exceeded with url: /subscriptions/08346c6c-bd12-45ad-8717-ba1c28f94648/providers/Microsoft.Network/locations/eastus/operations/a3b14682-9cd4-4fcd-acc4-cfb009fa581b?api-version=2017-09-01 (Caused by SSLError(CertificateError("hostname 'arm-rpfd-prod.trafficmanager.net' doesn't match either of 'management.azure.com', 'isp3.management.azure.com', 'admin.management.azure.com', 'northcentralus.management.azure.com'",),))

    Because of this, I cannot delete vnet-gateway, the public ip that was created for it, the vnet and the vnet resource group. 

    Can someone from the Azure team have a look at this please?


    • Edited by Sergei Ryabkov Wednesday, November 15, 2017 2:09 AM remove style tags
    Wednesday, November 15, 2017 2:06 AM

Answers

  • Hi Sergei, 

    I have seen this happen here and there in the Portal. 

    Can you wait about 2 hours and see if the issue is still there? We have a timeout of 90 mins for operations on the back end. So it is best to wait that entire time to see if the operation actually times out and fails rather than continue to stack additional delete operations on top. 

    Let me know the status after the 2 hour mark from the last delete operation you implemented and if there is still a problem we can take a look. 

    Thanks :) 

    -Micah

    Wednesday, November 15, 2017 3:40 AM
    Moderator

All replies

  • Hi Sergei, 

    I have seen this happen here and there in the Portal. 

    Can you wait about 2 hours and see if the issue is still there? We have a timeout of 90 mins for operations on the back end. So it is best to wait that entire time to see if the operation actually times out and fails rather than continue to stack additional delete operations on top. 

    Let me know the status after the 2 hour mark from the last delete operation you implemented and if there is still a problem we can take a look. 

    Thanks :) 

    -Micah

    Wednesday, November 15, 2017 3:40 AM
    Moderator
  • Hi Micah,

    When I woke up this morning, the status of the vpn connection was "Failed" / "Not Found" (see the screenshot)



    I re-ran the delete command (az network vpn-connection delete --name vpn-connection-staging --resource-group rg-vnet-staging) in Azure Cloud Shell, and the resource got deleted with no issues. It took a couple of seconds. I was then able to delete all the other resources that had a dependency on the vpn-connection.

    So, the problem is resolved. Thank you for your advice.

    -Sergei


    Wednesday, November 15, 2017 11:41 AM
  • Great! Happy to hear it :) 

    -Micah

    Wednesday, November 15, 2017 4:43 PM
    Moderator