Cannot upload XAP. " Try again at a later time." RRS feed

  • Question

  • Hi there,
    since today I don't seem to be able to upload an update for one of my games. The xap is roughly 38Mb. It always took a while to upload but always succeded with no problems. 

    Since this morning, the message is alway :

    "We can't connect to the server at the moment. Try again at a later time."

    Im on a DSL connection. I've also tried on a optical fiber connection and still the same result (although admittedly faster). I've used Chrome on the DSL connection and IE 9 on fiber.

    Anything more I can try?


    Wednesday, August 22, 2012 1:30 PM


All replies

  • Hi there Pansoft -

    Sorry to hear about the upload issues you are currently having. We are currently trying to track down the various upload issues. If you could answer a couple of questions, that would be a big help.

    When do you get that message? Is it immediately after you start or upload or a little ways in? How long in?

    Right before you get that message, what message is on the screen? Is it saying Uploading, or is it saying Saving Info? (or something else?)


    Wednesday, August 22, 2012 3:41 PM
  • Hi again,
    the message is after I try to upload the xap. To get the message, I follow these steps :

    - Go to 'Upload and describe your XAP' section
    - Click on "update selected"
    - Browse and pick my Xap
    - An overlay window appears telling me 'Uploading file...' and the name of my Xap

    After about 2 minutes I get the error. It takes longer when I'm on slower connection. On a faster network it takes significantly less, but the error is the same.

    If I do not try to upload the new Xap and just select the save buton, every other info on the page is saved correctly.


    Wednesday, August 22, 2012 4:17 PM
  • Replying to my own thread sorry.

    I've found yet another behaviour on another machine, from yet another network type : after the uploading process seems to end, I just get the warning icon and not error text at all. I've no errors about the upload but still the warning icon appears so I don't know if something bad or good has happened.

    As it is right now, its still impossibile to upload a big Xap, at least for me.


    Thursday, August 23, 2012 9:30 AM
  • Hello,

    I'm really disappointed, because I'm still not able to upload any apps bigger than about 8 MB because of a timeout that happens. I'm really tired of visiting and paying in Internet Café in town just to upload a simple app! Why doesn't Windows Phone Dashboard work as well as Windows 8 Metro Dashboard does? I have no problems uploading even 100 MB apps there.

    If anyone else has the same issue, please leave a reply to show that I'm now not alone in this.

    Thank you

    Friday, August 24, 2012 6:54 PM
  • I'm joining with the same issue. My answers-

    The error shows up after about 4 minutes of "uploading" a 20 MB app (The Quote - update), the message is showing Uploading...

    This has definitely something to do with timeouts. Maybe something wrong with Silverlight timeouts - on Windows 8 Dev Center I am able to upload much, much bigger apps without problems.

    Thank you very much for trying to resolve this problem.

    Friday, August 24, 2012 7:19 PM
  • I wanted to give an update. We have been working on several solutions to address your issues with uploads not being able to complete and those solutions should be rolling out soon.

    Thank you for your patience!

    Tuesday, August 28, 2012 8:24 PM
  • Great! Hope it will help :-) .
    Tuesday, August 28, 2012 10:50 PM
  • I am getting the same error with different scenario. I am doing an update of an existing app (347fea01-a5a6-48ae-afb4-892ecf6a5320), with 10 languages.

    This happens to me when trying to delete one of the screenshots so I can replace it with a new one. It gives the error immediately on pressing the Remove button - there is no wait period.

    I have 10 languages, and interestingly I have not had the problem with some of the languages. But with others - always the same languages (e.g. US English, Dutch, Russian) - it always errors. For those languages where it fails - it fails with different screenshots: I have 8 screenshots - the failure is always on screenshot 8; for English, 1-6 could be changed but not 7; for Russian 1-5 but not 6,7,8. This appears to be nothing to do with network bandwidth and I would think should be reproducible at MS with what I have described.

    I could try to submit my update without changing the screenshots but really don't want to do that.

    Any status update on this problem?

    Friday, September 7, 2012 7:26 AM
  • A temporary workaround for your issues with deleting a screenshot can be found on this forum post:


    We are aware of this issue and hope to have a fix out soon (at the same time as fixes for the issues around uploading XAPs).


    • Marked as answer by Danny G. - MS Wednesday, September 12, 2012 4:19 AM
    Monday, September 10, 2012 9:20 PM