locked
Not able to delete Azure VM RRS feed

  • Question

  • I Create VM  using ARM Template but by adding  links in osdisk and disk in vm Profile, may this is a main issue i thought.

    Arm Template : Osdisk and disk code where i added vhd: uri:"https://foobar.blob.core.windows.net/vhds/foobar-os.vhd"

    "osDisk": {
                "osType": "Linux",
                "name": "prasadtest101",
                "createOption": "FromImage",
                "vhd": {
                  "uri": "https://foobar.blob.core.windows.net/vhds/foobar-os.vhd"
                },
                "caching": "ReadWrite"
              },
              "dataDisks": [
                {
                  "lun": 0,
                  "name": "prasaddatadisk101",
                  "createOption": "Empty",
                  "vhd": {
                    "uri": "https://foobar.blob.core.windows.net/vhds/foobar-data.vhd"
                  },


    Error showed in Azure portal while deleting Azure VM: 

    Failed to delete the virtual machine 'MyUbuntuVM'. Error: One or more errors occurred while preparing VM disks. See disk instance view for details.

    Please help to resolve this issue. 



    Friday, October 12, 2018 7:09 AM

All replies


  • In order to find out what's causing the deployment failure in your script, please go to https://resources.azure.com there you will be able to check the InstanceView mentioned in error message you are getting when trying to delete your VM.

    In Resource Explorer expand Subscriptions->(select your subscription)->Resource Groups->(select resource group in which your VM is located)->Providers->Microsoft.Compute->Virtual Machines->InstanceView

    In the right pane look for any status messages that indicate a failure and correct it in your script. 

    If this answer was helpful, click “Mark as Answer” or Up-Vote. To provide additional feedback on your forum experience, click Here


    Friday, October 12, 2018 1:36 PM
  • I already try with this option but it did't work
    Monday, October 15, 2018 9:03 AM
  • The error proposes to 'See disk instance view for details'.

    Can you provide these details?

    Monday, October 15, 2018 1:40 PM
  • Main issue is that my os disk and disk is attached with the Azure vm but problem is that there is no vm just only show vm name in the resource group.There is no nic, storage , vet and subnet.

    just only one not found azure vm through which disks are linked and those disks are also failed and not created and not showing in resource group .

    I did't understand how to remove that vm .


    Monday, October 15, 2018 1:52 PM
  • In that case it looks like some internal error. Try to delete the Resource Group and repeat the process. The ARM template was based on an example from the github gallery or was is built from scratch?

    Tuesday, October 16, 2018 11:53 AM