visual studio 2015 not working anymore after reinstall RRS feed

  • Question

  • I uninstalled visual studio 2015. Then I deleted the folder \Program Files (x86)\programming1\Microsoft Visual Studio 14.0

    and its contents. Then I renamed all instances of Program Files (x86)\programming1\Microsoft Visual Studio 14.0

    in the registry to Program Files (x86)\programming\Microsoft Visual Studio 14.0

    as well as Program Files (x86)/programming1/Microsoft Visual Studio 14.0 in the registry renamed to

    Program Files (x86)/programming/Microsoft Visual Studio 14.0

    (note the difference being the forward or back slash, and programming1 renamed to programming ie without the 1).

    The reason I did this is because I had typed a typing mistake with the "1" after programming and wanted the correct location for my installation but it's not possible to change the installed directory after installation so I had to uninstall and then reinstall it.

    After that I reinstalled visual studio 2015 but it came up with an error that the C++ 2015 redistributable (64bit and 32bit) could not be installed. So I uninstalled those from the control panel, and then I was able to install Visual Studio 2015 community edition. However when I try to compile things it says the compiler is missing. I tried running the install and click on "repair" which takes ages but afterward the problem is still there.

    An example error message in visual studio is:

    Severity    Code    Description    Project    File    Line
    Warning        A problem occurred while trying to set the "References" parameter for the IDE's in-process compiler. Project 'Greenshot.ImageEditor' could not be opened because the Visual C# 2015 compiler could not be created. Please re-install Visual Studio.    Greenshot.ImageEditor        

    I have a feeling that there might be components marked as installed in the registry now, that are actually missing in the file system due to the fact that I had deleted the "Microsoft Visual Studio 14.0" folder. So that the visual studio installation is thinking it doesn't need to reinstall them anymore, when in fact it does ??

    Update on this issue: I have managed to reinstall visual studio 2015 community edition and the compiler is now working. What I had to do was to install using the default options, instead of clicking custom and telling it to install everything.

    Wednesday, February 3, 2016 6:35 AM


  • Hi my friend,

    Thank you for posting in MSDN forum.

    Glad to hear you have solved this issue successfully.And thanks for sharing us your result and solution here.

    The solution is to install using the default options, instead of clicking custom and telling it to install everything.

    If you think your post is helpful, please mark my reply as the answer, it will benefit to other community members who have the same issue. It will be easier for them to search the solution.

    Have a nice day:)

    Best Regards,

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Proposed as answer by 宝宝徐 Friday, February 5, 2016 1:48 AM
    • Marked as answer by 宝宝徐 Wednesday, February 17, 2016 1:37 AM
    Thursday, February 4, 2016 8:26 AM