locked
the application failed to initialize properly (0xc000007b) RRS feed

  • Question

  • User1030579881 posted

    Started to get this error message pop-up whenever I attempt to run a web app or winforms app. The problem first appeared when I was trying to run a simple winforms app I had written. I'd been running and testing this app without any problems until this error message started to appear.

    Then I found that my web apps would not run via Visual Studio 2005 file sytem. ("Visual Studio could not connect to server"... can't remember exact wording) . I read in a another forum to try running WebDev.Webserver.exe direct from the command line. I tried this but got the "the application failed to initialize properly (0xc000007b)" error pop-up. Other forums stated that the probable cause was a corrupt WebDev.Webserver.exe file. But the same error pop-up occurs on all my winforms desktop apps too.

    Also, I get the "the application failed to initialize properly (0xc000007b)" pop-up whenever I try to compile my web apps using aspnet_compiler.exe.

    My web apps will run via VS 2005 if I do "Open website via Localhost" rather than "Openwebsite via File System". My winforms apps will not run at all.

    I can't think of anything I did or anything which occured to start this problem happening. Everything was working fine one day and not the next. My machine is a laptop running XP SP2, .NET 2.0, and Visual Studio 2005 Professional with all the service pack updates. I tried a full repair/install of VS 2005 with no effect. I completely uninstalled and reinstalled the 2.0 .NET framework. I have also run a SFC /scannow for XP which didn't turn up anything.

    I suspect a virus of some kind, but the latest spybot and adaware do not turn up anything. 

    I'm stumped. Has anyone else experienced this problem?

    Thanks in advance,

    Paul

     

    Tuesday, February 19, 2008 7:23 AM

All replies

  • User1030579881 posted

    In case anyone is interested...

    Seems my laptop had picked up a particularly nasty virus/trojan "Win32.dell.uc". This is evidently malware of the "nuker" variety. The latest Spybot detected it but could not eliminate it. The malware had corrupted a lot of Windows system files. I tried sfc/scannow and an XP repair but nothing worked. Eventually I gave up and did a complete reformat disk/reinstall of XP and  all my development tools. My laptop is now clear and everything works as it should. I also changed all my passwords locally and on every protected site I use.

    I'm super careful about opening emails and I can't think how this nasty piece of work got onto my system. 

    It's gone now, but caused me a lot of wasted time and effort.

    Hope this helps someone else. 

     

    Monday, February 25, 2008 10:14 AM
  • User-26861744 posted

    Noooooooooooo I don't want to format again. Please another way? If you inform me something different I will be so happy.

    email:yasar_akyar@hotmail.com

    Regards...

    Tuesday, November 3, 2009 1:42 PM