none
Error in WCF-WSHttp Adapter RRS feed

  • Question

  • Hi everybody.

    After install Biztalk 2013 and ESB Toolkit, I try to run ESB.ExceptionHandlingServices.WCF service from IIS, but it throw an exception:

    The Messaging Engine failed to register the adapter for "WCF-WSHttp" for the receive location "/Test/TransformationService.svc". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.

    I've search in google, I sure that AppPool that my BizTalk web service running under was the same account as the Isolated Host Instance. But not resolve.

    Also the "ESB.TransformServices.WCF" service work fine (same account with TransformationService.svc AppPool)

    Please help me! I've tried to solve 3 days but cannot.

    Thanks


    • Edited by So Hai Saturday, May 17, 2014 5:05 AM
    Saturday, May 17, 2014 5:04 AM

Answers

  • I found the problem, I chose "Do not use Default Binding" option in "Enable ESB Core Components In BizTalk Server"

    :)

    • Proposed as answer by DeepthiAdith Thursday, May 22, 2014 2:38 PM
    • Marked as answer by Pengzhen Song Friday, May 23, 2014 8:58 AM
    Saturday, May 17, 2014 9:20 AM

All replies

  • I found the problem. There is not any receive location in Microsoft.Practices.ESB Application.

    But I don't know why it is missing those when set up ESB Toolkit 2.2

    Saturday, May 17, 2014 7:25 AM
  • Please try reconfiguring the ESB Tools, there is some issue in your configurations.

    If this answers your question please mark as answer. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Saturday, May 17, 2014 8:47 AM
  • I found the problem, I chose "Do not use Default Binding" option in "Enable ESB Core Components In BizTalk Server"

    :)

    • Proposed as answer by DeepthiAdith Thursday, May 22, 2014 2:38 PM
    • Marked as answer by Pengzhen Song Friday, May 23, 2014 8:58 AM
    Saturday, May 17, 2014 9:20 AM