locked
Strange behaviour on windows server 2012 RRS feed

  • Question

  • User1256512446 posted

    Hi all:

    I have a script

    bdcuerpo.Attributes.Add("onload", "if (opener.document.getElementById('ctl00_cphcontenido_gvobras_" & Request.QueryString("id") & "_lblreactivacion')) {opener.document.getElementById('ctl00_cphcontenido_gvobras_" & Request.QueryString("id") & "_lblreactivacion').innerHTML='" & strfecha2 & "';}")

    I write a date on an open page, page2, that opens from page1.

    On Windows server 2012 I can't write on the page. On Windows 7 I can do that without any problem

    Why? I disabled the enhanced security.

    TIA

    Saturday, January 16, 2016 7:05 PM

Answers

  • User-986267747 posted

    Hi volar5,

    On Windows server 2012 I can't write on the page. On Windows 7 I can do that without any problem

    According to your description, your code works fine on windows 7, but it's not works on Windows server 2012. isn't it? When you run your project on Windows server 2012, you could use the F12 Developer Tools to debug your code in client side and check if you get some error messages in your browser.

    Why? I disabled the enhanced security.

    You suspect that you disabled the enhanced security and it caused this problem, isn't it? you could try to enable the enhanced security and check if you still get the same problem.

    Best Regards,

    Klein zhang

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 18, 2016 2:57 AM

All replies

  • User1256512446 posted

    Hi again:

    It is clear to me maybe it is a problem in security configuration in Windows server 2012 r2. It doesn't accept the html5 API.

    TIA

    Sunday, January 17, 2016 1:46 PM
  • User-986267747 posted

    Hi volar5,

    On Windows server 2012 I can't write on the page. On Windows 7 I can do that without any problem

    According to your description, your code works fine on windows 7, but it's not works on Windows server 2012. isn't it? When you run your project on Windows server 2012, you could use the F12 Developer Tools to debug your code in client side and check if you get some error messages in your browser.

    Why? I disabled the enhanced security.

    You suspect that you disabled the enhanced security and it caused this problem, isn't it? you could try to enable the enhanced security and check if you still get the same problem.

    Best Regards,

    Klein zhang

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 18, 2016 2:57 AM