locked
asp.net website administration tool error RRS feed

  • Question

  • User9340443 posted

    Hi, I have a question.

    When I was using website administration tool it gives me error like this.

    An error was encountered. Please return to the previous page and try again.

    The following message may help in diagnosing the problem: Unable to initialize the native configuration support external to the web worker process (HRESULT=0x80004002). nativerd.dll must be in %windir%\system32\inetsrv. at System.Web.Configuration.ProcessHostConfigUtils.NativeConfigWrapper..ctor() at System.Web.Configuration.ProcessHostConfigUtils.InitStandaloneConfig() at System.Web.Configuration.ProcessHostMapPath..ctor(IProcessHostSupportFunctions functions) at System.Web.Configuration.IISMapPath.GetInstance() at System.Web.Configuration.HostingPreferredMapPath.GetInstance() at System.Web.Configuration.WebConfigurationHost.ChooseAndInitConfigMapPath(Boolean useConfigMapPath, IConfigMapPath configMapPath, ConfigurationFileMap fileMap) at System.Web.Configuration.WebConfigurationHost.InitForConfiguration(String& locationSubPath, String& configPath, String& locationConfigPath, IInternalConfigRoot configRoot, Object[] hostInitConfigurationParams) at System.Configuration.Configuration..ctor(String locationSubPath, Type typeConfigHost, Object[] hostInitConfigurationParams) at System.Configuration.Internal.InternalConfigConfigurationFactory.System.Configuration.Internal.IInternalConfigConfigurationFactory.Create(Type typeConfigHost, Object[] hostInitConfigurationParams) at System.Web.Configuration.WebConfigurationHost.OpenConfiguration(WebLevel webLevel, ConfigurationFileMap fileMap, VirtualPath path, String site, String locationSubPath, String server, String userName, String password, IntPtr tokenHandle) at System.Web.Configuration.WebConfigurationManager.OpenWebConfigurationImpl(WebLevel webLevel, ConfigurationFileMap fileMap, String path, String site, String locationSubPath, String server, String userName, String password, IntPtr userToken) at System.Web.Configuration.WebConfigurationManager.OpenWebConfiguration(String path) at System.Web.Administration.WebAdminPage.OpenWebConfiguration(String path, String appPhysPath, Boolean getWebConfigForSubDir) at System.Web.Administration.WebAdminPage.OpenWebConfiguration(String path, Boolean getWebConfigForSubDir) at System.Web.Administration.WebAdminPage.OpenWebConfiguration(String path) at ASP.providers_manageproviders_aspx.ParentProviderCount(String serviceName) at ASP.providers_manageproviders_aspx.BindProviderLists() at ASP.providers_manageproviders_aspx.Page_Load() at System.Web.Util.CalliHelper.ArglessFunctionCaller(IntPtr fp, Object o) at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    What should I do. I can't do anything with it. 

    Please help me. Thank you very much.

     

    Monday, June 11, 2007 3:28 AM

Answers

All replies

  • User76536425 posted

    Have you checked that nativerd.dll is in \Windows\System32\inetsrv?

    If so, check this thread for some other ideas: http://forums.iis.net/t/1119822.aspx 

    Don 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 11, 2007 11:25 AM
  • User-2034129096 posted

    Has anyone found a solution for this, as I get the same error when I try and debug or compile from inside vs 2005.  I tried uninstalling and re-install IIS and VS 2005 and still no luck....  ANyone have a solution for this?

    Thursday, June 21, 2007 9:56 AM
  • User1450044881 posted

    Just to pile on...  am having the same issue... appreciate any guidance

    Thursday, July 5, 2007 10:18 PM
  • User175012386 posted

     i'm also having the same issue and scarier, i don't know the cause.  since this issue i can't get intellisense working anymore in design or code views.  help!

    Friday, July 6, 2007 11:20 PM
  • User-604952279 posted

    I'm having the same issue. Please help

    Monday, July 9, 2007 2:42 PM
  • User2019917201 posted

    I also having same issue but i having issue in vista ultimate 64 bit, it's working good if we open website from filesystem location, it's only not working when we try to open with IIS web application.

    so may be problem with IIS 7.0 and vista with VS2005, i have also applied SP1 to VS2005 fo vista.

    pls  tell me is anyone knows it's solution.

     

     

    regards,

    vijay

    Monday, July 23, 2007 7:35 AM
  • User175012386 posted

     i fixed my issue.  it was a conflicting asp.net ajax prefix.  once i changed <asp> to <ajax> all became well again.  i hope this helps.

    Monday, July 23, 2007 7:58 AM