locked
vs.net & debug broke iis? RRS feed

  • Question

  • User1738232508 posted
    I've got a thread going in the dotnetnuke forum that has me absolutely stumped and loosing my mind. <post>595293</post> The described behaivior first happend on my laptop about 10 days ago and I gave up... but now it happened on my desktop yesterday and I can't work until its fixed. Basically: I was debugging a program in vs.net 2003 and the debug & vs.net froze up. I had to 'End Program' on vs.net. When I tried to open the web project back up all I get is: "Contacting server top open Web project 'projectname'" and nothing happens... it just sits like this until I end program again. I then tried to browse to the site in IE however it just sits and tries to load forever as well. My setup ---------- WinXP VS.NET 2003 ASP.NET 1.1 This machine is being used as a development machine and is only accessed via localhost My troubleshooting steps thus far have been: -Virus scan (turned out negative) -Check Event Log (empty) -Create new directory & web app for project -Clear out %windir%\microsoft.net\framework\v1.1.4322\Temporary ASP.NET Files -run %windir%\microsoft.net\framework\v1.1.4322\aspnet_regiis -i -run IISRESET -finally reinstall IIS I'm flat out stumped... any ideas?
    Thursday, June 10, 2004 2:57 PM

All replies

  • User989702501 posted
    Ok. you pretty much done everything now. So after you reinstall, does IIS serves plain html file? XP only allow one site to be active and running at anytime. so make sure you only have 1 running. what other special application you have in the box?
    Thursday, June 10, 2004 10:04 PM
  • User1738232508 posted
    Digging through the webserver logs and doing testing on my desktop I have notice the following: First I tried to access: localhost/dotnetnuke/404.htm 12:57:25 127.0.0.1 GET /dotnetnuke/404.htm 401 (Unauthorized) 12:57:25 127.0.0.1 GET /dotnetnuke/404.htm 206 (Partial Content) Nothing came up and IE just sat in the trying to access mode with the little animation in the upper right moving. I tried renaming 404.htm to 404.shtml localhost/dotnetnuke/404.shtml 13:43:03 127.0.0.1 GET /dotnetnuke/404.shtml 401 (Unauthorized) 13:43:03 127.0.0.1 GET /dotnetnuke/404.shtml 200 (OK) Content DID come up normal localhost/dotnetnuke/404.html 13:44:45 127.0.0.1 GET /dotnetnuke/404.html 401 (Unauthorized) 13:44:45 127.0.0.1 GET /dotnetnuke/404.html 200 (OK) ... even though the log gave a '200' ... no content displayed and IE was stuck in trying to access page localhost/dotnetnuke/spacer.gif 13:48:11 127.0.0.1 GET /dotnetnuke/spacer.gif 401 (Unauthorized) 13:48:11 127.0.0.1 GET /dotnetnuke/spacer.gif 200 (OK) ... even though the log gave a '200' ... no content displayed and IE was stuck in trying to access page localhost/dotnetnuke/default.aspx 13:50:47 127.0.0.1 GET /dotnetnuke/default.aspx 200 (OK) This is where it gets the most wierd. the page apparantley processed and content even came back to me (from database and all)... but the content was all screwed. I looked at the 'view source' for the page, and while content was there, the begining of the page is missing (...its like IIS decided to start transfering part of the way through... which makes sense considering the 206 status code on the .htm file requests)... any way, the view source starts with: class="HeadBg"> ... Notice there is is no <HTML><HEAD> etc to start the doc... It is very wierd that requesting a .shtml file worked just fine.
    Friday, June 11, 2004 11:42 AM
  • User989702501 posted
    Look like permissions issues. If you try trace with it Filemon (sysinternals.com) any luck ? 401 error as in login related or ACL issue ? 401.1 - Logon failed. 401.2 - Logon failed due to server configuration. 401.3 - Unauthorized due to ACL on resource. 401.4 - Authorization failed by filter. 401.5 - Authorization failed by ISAPI/CGI application. 401.7 – Access denied by URL authorization policy on the Web server. I believed you don't have any problem accessing ssinc.dll, hence requesting .shtml file didn't give you any problem.
    Sunday, June 13, 2004 10:02 PM
  • User1738232508 posted
    I played around with filemon, but i'm not too sure what to make of all of it... when I request a page (ie localhost/404.htm) IE gets 100+ entries in Filemon... I did see one entry that said IUSR account didn't have access to the file. ASPNET account has full control of the directory... so I figured this would be enough, but just for good measure I granted IUSR account access to the 404.htm file for testing... this removed the 401 error... however: I still got a few 206 errors on requests... and I even got a hadfull of plain ole' 200 (success)... but no content served, and IE just sat there "thinking" even though the log showed 200. I did find this oddity in filemon when requesting localhost/404.htm 9:09:49 AM inetinfo.exe:2144 OPEN C:\WWWDIR\404.HTM SUCCESS Options: Open Access: All 9:09:49 AM inetinfo.exe:2144 QUERY SECURITY C:\WWWDIR\404.HTM SUCCESS 9:09:49 AM inetinfo.exe:2144 QUERY INFORMATION C:\WWWDIR\404.HTM SUCCESS FileFsVolumeInformation 9:09:49 AM inetinfo.exe:2144 QUERY INFORMATION C:\WWWDIR\404.HTM BUFFER OVERFLOW FileAllInformation 9:09:49 AM inetinfo.exe:2144 READ C:\WWWDIR\404.HTM SUCCESS Offset: 0 Length: 3658 9:09:49 AM inetinfo.exe:2144 CLOSE C:\WWWDIR\404.HTM SUCCESS
    Monday, June 14, 2004 10:32 AM
  • User1738232508 posted
    Got this figured out... apparently the new version of zonealarm (5) is causing major problems with IIS... I am reverting back to 4.5 I can't believe I went that far into troubleshooting without thinking about firewall.... oh well. Thanks all for your help.
    Monday, June 14, 2004 11:45 AM
  • User989702501 posted
    Yes! I asked you before 'do you have special application in the box?' :) Glad to know it's working now.
    Monday, June 14, 2004 10:47 PM