locked
Windows Store printing problem in xaml RRS feed

  • Question

  • Hi,

    I don't know if anybody has run into this.

    I am following the windows store printing sample, and I have practically the same setup.

    The problem I have is that when the content reaches past the first page, some of the pages are no longer being printed.

    The print preview seems to be working fine however.

    • If it's a single page, it works.
    • If it's multi-page, the first page is missing from the final print list.
    • If it's multi-page and changed to landscape mode, it works.

    I have been trying to fix this for a week now and I don't seem to be going anywhere.

    Has anybody run into this? If anyone wants to see a specific part of the code, please let me know.

    I didn't post anything because it's largely the same as the sample.

    Thanks in advance!

    - Kenneth

    • Edited by coldhead_2000 Wednesday, September 11, 2013 5:19 PM some layout update
    Wednesday, September 11, 2013 4:44 AM

Answers

  • I figured it out.

    If one of your page component (in my case, a grid inside InlineUIContainer) runs over the width of your RichTextBlock, the page is skipped silently. This seems to be really silly as the print status came back as Submitted where it obviously failed.

    Now I made sure my elements are well inside the RTB and printing seems to be fine now.

    • Marked as answer by coldhead_2000 Thursday, September 12, 2013 1:09 AM
    Thursday, September 12, 2013 12:33 AM

All replies

  • Update:

    • Different papersize seems to have different effects - missing different random pages
    • Preview still always looks good
    Wednesday, September 11, 2013 11:52 PM
  • I figured it out.

    If one of your page component (in my case, a grid inside InlineUIContainer) runs over the width of your RichTextBlock, the page is skipped silently. This seems to be really silly as the print status came back as Submitted where it obviously failed.

    Now I made sure my elements are well inside the RTB and printing seems to be fine now.

    • Marked as answer by coldhead_2000 Thursday, September 12, 2013 1:09 AM
    Thursday, September 12, 2013 12:33 AM