none
Issue integarting App Insights with AzureDevOps RRS feed

  • Question

  • Hi guys,

    I was attempting to setup the Application Insights integration with Azure DevOps for Work Items, to be able to easily log issues in our backlog, appearing on an application that is about to go live.

    In the portal, on my Application Insights instance, under Wrok items, once the form was filled with the right information, and authorised successfully, on submission, the following error pops up ( with no error code preceeding it, or any other similar identification properties ):

    Method not found: 'Void Newtonsoft.Json.Serialization.JsonDictionaryContract.set_PropertyNameResolver(System.Func`2)'.

    Any ideas on how to get this working, or what might be causing this, would be much appreciated, as I would like to get this feature working on this project.

    Many thanks,

    Vlad

    Thursday, May 9, 2019 2:26 PM

All replies

  • Vlad,

    We've seen reports similar to yours.  Did you build for .NET 4.6? 4.6 is not automatically supported in Azure Cloud Services roles. Install 4.6 on each role before running your app.

    https://docs.microsoft.com/en-us/azure/azure-monitor/app/asp-net-troubleshoot-no-data#exception-method-not-found-on-running-in-azure-cloud-services



    Tuesday, May 14, 2019 12:23 AM
    Moderator
  • Hi there,

    Unfortunately I think maybe my issues was misunderstood. I don't have any problems getting telemetry from my application to App Insights, nor do I have any problems with my application.

    My issue is in enabling the Work Items feature on the application insights instance, in the Azure Portal, to be able to create work items from telemetry, directly from the Azure Portal ( I am talking about this feature: https://azure.microsoft.com/en-gb/blog/application-insights-work-item-integration-with-visual-studio-team-services/ ).

    I hope this makes it a bit clearer.

    EDIT:

    Tuesday, May 14, 2019 8:33 AM
  • Vlad,

    The best guidance I can recommend right now is the Work Items blog by Mike Gresley (Senior Program Manager for Application Insights).  I have run into the Authorization issue and am continuing to investigate this.

    Thursday, May 16, 2019 1:49 AM
    Moderator
  • Yep, I've cross-checked that I have followed the documented steps of doing it, but no joy.

    I have done it in the past for other projects, so it came as a bit of surprise when I haven't managed to get it working now, as I don't seem to have done anything differently

    Tuesday, May 21, 2019 11:54 AM
  • Vlad,

    This ended up being my reproduction steps.  Let me know how they compare to your steps:

    1. In Azure DevOps, click on + Create project in the upper right
    2. Give the project a name
    3. Click on Advanced, and select a Work item process (I selected Agile)
      Note: Basic will be selected by default, and it is the only option that does not support the "Bug" type which we will need to complete the Application Insights setup.
    4. Copy the URL from DevOps (in this case, mine was https://dev.azure.com/kobulloc-appins-workitem/AppIns-WorkItemTest-Agile)
    5. Navigate to your Application Insights resource in the Portal, and select Work Items
    6. For URL, use everything but the project name you just created (see below)
    7. For Project, use the project name you just created
    8. For Area, I used the project name again
    9. Click on Authorize
      Note:  There are two bugs here which we are working to resolve which have workarounds:
      a)  Here I got a popup that wouldn't close, but the url ended with "=Valid".  I closed the popup manually.
      b)  Clicking OK the first time around resulted in the error "Please setup authorization to tracking system".  I switched tabs (clicked on Alerts), then switched back to Work Items.
    10. Click on OK

    Monday, June 10, 2019 5:34 AM
    Moderator
  • Apologies for the late response, as I have kind of given up on setting this feature up for that project. I will give it another try as soons as I can, and will update my response accordingly. I have managed to set this up just fine for other projects though, which is why I found this issue a bit weird. 

    3rd July Edit:

    I have given it another try for that particular project, and, I am getting the same result as previously:

    One or more errors occurred. Method not found: 'Void Newtonsoft.Json.Serialization.JsonDictionaryContract.set_PropertyNameResolver(System.Func`2)'.

    Just no luck with it. This is the only bug I am running into tho, haven't had problems with the authorization or pop-ups.



    Wednesday, June 26, 2019 11:28 AM
  • I am experiencing the same exact issue.

    

    Wednesday, July 17, 2019 10:07 PM
  • I want to give an update here:

    • The issue has been brought to the attention of the product group
    • It's been triaged, and they are looking into it
    • While I'd love to report an immediate solution, more likely we're about a month out
    • We'll update the thread as there are more details

     

    Thank you so much for your patience, and please report any additional information you have here.



    Monday, July 29, 2019 4:42 PM
    Moderator