none
remove required field validation

    Question

  • Hi

    I want to remove a required filed validation in biztalk,

    below is the message i have

    MSH|^~\&|XyZ|XYX Clinics,52||16|20161120061635||ORU^R01|907|P|2.3
    PID|1|CEU-000119|11670||Khan^Saleem^NA||19840512120000|M|||||||
    ORC|RE|ON1151||16|CM||^^^^^R^^^^||20161120|||4782^Doctor^Hl7^^^
    OBR|1|ON1151|ON1151|450^Blood Culture^^450^Blood Culture^|R|20161120000000|20161120000000|||||||20161120000000||||http://abc.com/Pages/Master/PrintingHandler.ashx?rn=ResultSubServices\T\UserName=adminnt\T\RegistrationClinicServiceId=35547\T\ReportName=Blood+Culture\T\BranchName=xyacb+Main+Clinics\T\BranchId=52\T\UserTimeZoneId=UTC\T\Hijri=0\T\OffsetTime=0\T\IsWebResult=1\T\un=adminnt\T\ip=\T\rcopy=false|||^^^^^^|20161120061635|||F||||
    OBX|1|TX|4643^Isolated Organism(s) (Blood Culture)^^4643^Isolated Organism(s) (Blood Culture)^||60|AI|59--62,--||||F|||20161120061635|^^^^^^|
    OBX|2|TX|7252^Gram Stain(Blood Culture)^^7252^Gram Stain(Blood Culture)^||50|AI|45--55,--||||F|||20161120061635|^^^^|

    the OBR 27 is empty,

    BizTalk reports me

    Segment Id: OBR
    Sequence Number: 1
    Field Number: 27
    Error Number: 101
    Error Description: Required field is missing
    Encoding System: HL79999

    I don't expect and want any value in this field and want to bypass the error.

    Is there any way to do that.


    • Edited by noor syed Sunday, November 20, 2016 4:53 PM
    Sunday, November 20, 2016 4:52 PM

Answers

  • Hi,

    If you dont expect any value then make it optional by setting its minoccur as 0 in the field properties.

    If you still get some vale validation error then set “Suppress Empy Nodes” Property to “No” at the Schema Level(By Clicking on the word “Schema” above the root node of the flatfile).

    refer; https://sandroaspbiztalkblog.wordpress.com/tag/flat-file-schema/

    Regards,

    Sharad Verma

    • Proposed as answer by Alex_par Monday, November 21, 2016 4:46 AM
    • Marked as answer by noor syed Tuesday, November 22, 2016 11:04 AM
    Sunday, November 20, 2016 5:47 PM

All replies

  • Hi,

    If you dont expect any value then make it optional by setting its minoccur as 0 in the field properties.

    If you still get some vale validation error then set “Suppress Empy Nodes” Property to “No” at the Schema Level(By Clicking on the word “Schema” above the root node of the flatfile).

    refer; https://sandroaspbiztalkblog.wordpress.com/tag/flat-file-schema/

    Regards,

    Sharad Verma

    • Proposed as answer by Alex_par Monday, November 21, 2016 4:46 AM
    • Marked as answer by noor syed Tuesday, November 22, 2016 11:04 AM
    Sunday, November 20, 2016 5:47 PM
  • Hi Sharad,

    thanks for your response

    I have HL7 accelerator schema and it doesn't allow to modify properties. any other way to do achieve this


    Monday, November 21, 2016 4:11 AM
  • You can modify the min occurs and max occurs properties in the segments.xsd and then rebuild the projects...Your change will reflect

    Regards


    Mandar Dharmadhikari

    Monday, November 21, 2016 4:14 AM
    Moderator
  • Hi,

    As suggested by Mandar.

    it is possible to modify the min Occurs and maxOccurs property in HL& schemas ..you can change the property in the Segments.xsd and then build the project, the changes will be reflected in the Main schema where those are imported.

    Regards, Sharad Verma

    Monday, November 21, 2016 4:46 AM
  • You can modify any Schema to support any agree modifications.

    However, very important, you really, really should have this modification documented between you and the other party, otherwise you are creating a risk for yourself by accepting possibly invalid HL7.

    Monday, November 21, 2016 3:00 PM
    Moderator