none
Workflow Manager config wizard won't get past blocked ports RRS feed

  • Question

  • Good afternoon, all!

    I'm trying to get Workflow Manager installed so I can do some dev.  The Configuration for Service Bus section of the Config Wizard has a problem seeing the open ports on the firewall for HTTPS port 9355 and Internal Communication Port Range 9000-9004.  These ports are specifically open in Windows Firewall.  I also tried setting this up with the "Enable firewall rules on this computer" tick boxes unchecked.  The Summary page shows the value FALSE, but I still get "port 9355 is blocked" and "port 9002 is blocked" . Netstat shows the ports in listening mode. 

    The installation string said it finished successfully, but I have some errors in the Application logs referring to the Service Bus Message Broker.  Apparently it crashed, but I restarted both the Message Broker and the Service Bus Gateway.  Don't know if these are significant, but it deserved mentioning.

    Thanks to all for looking!

    Gregg

    Monday, February 1, 2016 9:14 PM

All replies

  • UPDATE!!

    I did some more research and eventually, after a reboot, got the Service Bus config to complete by leaving and rejoining the farm.  Now, I can't get the host to add to the Workflow Manager farm.  The error at that point is:

    The remote server returned an error: (400) Bad Request. The api-version in the query string is not supported. Either remove it from the Uri or use one of '2012-03'..TrackingId:5ff02099-de8f-4684-a57d-c9879970027f_Gsharepoint1,TimeStamp:2/2/2016 5:45:18 PM

    Have to confess - never saw that before......

    Any thoughts on this? I may go back and look at the PowerShell commands and try that.....

    Thanks!

    Gregg

    Tuesday, February 2, 2016 5:50 PM
  • More Update!

    Dug out a posting about applying a hotfix for Service Bus - downloaded and applied and got a whole new error!

    Configuring Workflow Manager runtime settings.
    The remote server returned an error: (404) Not Found. The incoming request is not recoginzed as a namespace policy put request: Unrecognized policy type: SubscriptionDescription, http://schemas.microsoft.com/netservices/2010/10/servicebus/connect.TrackingId:b5ee0d2f-68fd-405f-880c-4037d86c090d_Gsharepoint1,TimeStamp:2/2/2016 6:15:00 PM

    Going to uninstall and reinstall......

    Gregg

    Tuesday, February 2, 2016 7:01 PM
  • OK, it's done!

    Left the farm,  logged in as the SharePoint admin account user, ran the configuration wizard and it's in!

    Lessons learned:

      1.  Anything affecting the SharePoint servers - use the SP Admin account.

      2.  Dig out all the CU's, patches, service packs, etc. and update them before configuating.

      3.  A reboot won't hurt, but may give you an entirely new set of errors to troubleshoot.

      4.  Always budget thrice the time you think it will take, not just the time you think it should take.

    Thanks!

    Gregg

    Tuesday, February 2, 2016 7:15 PM