none
Kinect not working (on and off) on a NUC D54250WYK, Please Advise! RRS feed

  • Question

  • Hi,

    I Have a brand new Intel nuc D54250WYK with windows 8.1, all updates (drivers and software) and Kinect is going on and off when running.

    I Run the Kinect V2 Configuration Verifier and is complaining with the USB controller "Supported USB 3.0 port detected with unknown bandwidth." 

    I just got the NUC (Core I5) and i checked the Kinect Requirements (USB 3) and is what i have. 

    What should i do ? 

    Please Advice,

    ==== Edit 1 ===

    KinectSDK-v2.0_1409

    i tried different ports, my last attempt: only Kinect connected (USB ports) the result is the same.

    I have more than $600 useless hardware, Any ideas?

    Regards


    Pedro

    Sunday, November 9, 2014 5:50 PM

All replies

  • We have run into a similar issue...this morning after plugging in the Kinects, the drivers or firmware automatically updated, and from that point forwards, we are experiencing the exact same thing.  The Kinect stays on for 20 or so seconds, turns off, then turns back on again.

    We're guessing it's a bad update, but it would be great to hear something official on this soon.

    Anyone else run into problems after the most recent update?

    Monday, November 10, 2014 8:42 PM
  • Have you installed the latest SDK? You must be running the final release version.

    As for the issue, this is expected behavior for systems that are exhibiting performance issues or limiting bandwidth. Have you tried to use the HighPerformance setting for the power management. Be sure also, you have turned off "Link State Power Management" 


    Carmine Sirignano - MSFT

    Tuesday, November 11, 2014 12:27 AM
  • Carmine, 

    Thanks for your suggestions. Still no luck, all the answers:

    1) SDK version, I've already mentioned KinectSDK-v2.0_1409, version: 2.0.1410.19000 Date: 10/21/2014 is the last one i found available for download, are you aware of another version ?

    2) High Performance setting: Yes is selected.

    3) Link State Power Management: off, this was off, i'm assuming is the default, i didn't changed (this is a brand new install)

    More details:

    4) I just updated the Intel NUC BIOS, before and after the update the result is the same

    5) USB driver: Intel USB 3.0 extensible Host Controller (has recommended)
    version: 6.3.9600.17031
    Date: 2/21/2014  
    No updates available.

    Carmine, what should i do ? How can i official report to the Kinect support team ? 

    I've everything as recommend, fresh installation, professional product, as MSFT partner do i need to raise a ticket ? 

    Please advise.

     


    Pedro

    Tuesday, November 11, 2014 2:06 AM
  • While the i5 should work, the minimum recommended hardware is actually an i7.

    http://msdn.microsoft.com/en-us/library/dn782036.aspx

    The team is aware of the issue on lower spec'd system, but there is no resolution to the issue at this time. 

    Are you able to reproduce with the SDK Browser samples? Do you see the same issues with the D2D vs the WPF samples?

    The behavior is by-design given the system is actively monitoring when we provide your application a notification that a frame is ready and the amount of time it takes for you to acquire the data and release it back. If that is taking too long, we will restart the KinectService.

    Depending on what your application is doing, system performance can affect what is happening. If you are doing any processing in addition to what the basics demonstrate, are you working with a copy of the data?


    Carmine Sirignano - MSFT

    Tuesday, November 11, 2014 6:20 PM
  • Carmine, 

    Rregarding the specs:

    When i bought the device i looked to the following specs:

    http://www.microsoftstore.com/store/msusa/en_US/pdp/Kinect-for-Windows-v2-Sensor/productID.298810500

    64-bit (x64), dual-core 2.66-Ghz or faster processor

    Unfortunately it seems there are different requirements, although are different CPUs (dual core 2.66 vs iCore 5)

    i wrongly assumed it was ok.

    I just bought the NUC i5 for a proof of concept involving a Kinect V2 and a PC with mobile capacities (small footprint, possible to be powered from battery, etc).

    I don't want to delay the next decision going back and forward to the development to check if is working  90% or 50% or nothing, it's a bad sign starting with the wrong options, and if there are tiny possibility the things can go wrong, it's better now then later.

    Can you answer the following points:

    1) It will be possible (I'm asking if there are plans to fix) to use Core i5 with Kinect V2, 100% or not ?

    2) If yes, when ? The reason why i'm asking is to be honest i don't know what to do with the brand new NUC, and recover the investment.

    Thanks for your time.

    Pedro


    Pedro

    Tuesday, November 11, 2014 8:03 PM
  • An i5 system has enough capability for Kinect. We have tested in various systems.

    I don't understand why Microsoft keeps pushing i7 CPU when they say GPU does most of the calculation.

    Intel HD Graphics 4400 or 4600 should be also fine as GPU according to our tests.

    Here are my observations that might help you somehow and also some info for the Microsoft team if they are interested.

    1. Running latest 1409-Release makes Kinect incompatible with 1408. Default sensor is not found in 1408. You have to use 1409. (Did not check though if this is also related my observation below)

    2. If the microphone array is deactivated / or detached, kinect freezes and starts to recapture repeatedly. This problem did not occur with 1408-PublicPreview but appears in 1409-Release.

    You can generate this issue by disabling "XBOX Nui Sensor" driver under "Sound, video and game controllers" in device manager.

    I suppose kinect service tries to run a function which employs microphone and expects a SUCCESS in return. Hence, it freezes when it receives failure. I would like to know if this is going to be changed.

    Tuesday, November 11, 2014 8:04 PM
  • Thanks for updating us with the scenario you have. Since you had hardware modified the sensor that is not a supported scenario. Because the runtime is not able to receive data from the sensor, it thinks something is wrong and will restart the pipeline, effectively restarting everything.

    Can you provide more detail as to why you removed the mic array? Can you reattach it as a way to work around your issue.


    Carmine Sirignano - MSFT

    Tuesday, November 11, 2014 11:24 PM
  • What's the final verdict ?

    I never remember to see anywhere i7 as min requirement ? Since when this changed ?

    I'm in the middle of a project, and i gave green light for an i5  (NUC, ZBOX, BRIX), i'm not 100% sure but i think my client went with Intel.

    10 locations for the first phase (Mid December) ? it will be a disaster !!!!

    Guys please don't play games !!!

    @Pedro, @Camine Any Updates ??? 

    --Jing

    Wednesday, November 12, 2014 1:08 AM
  • The official supported spec is to have an i7 which is listed above. If you have checked the power settings and tested with the D2D samples and are reproducing the issues, there is no quick fix other than different hardware. Additionally, please confirm this is a simple typical scenario where there is no hardware modified sensor connected directly to the device. Additionally, you are not trying to access this over RDP.

    What sample from the Toolkit have you tried that is reproducing the issue? Can you reproduce this on all Intel Nuc devices you have? If we got the engineering team one of these devices is he going to be able to reproduce it in a known working scenario?

    As for i5 vs i7, we have successfully held many hackathons using Surface 2 and 3 pro machines that have the i5 chipset. These machines run all of our samples and Kinect Evolution without issues.

    We also have used the Gigabyte Brix machines but it was the i7 version. 


    Carmine Sirignano - MSFT


    Wednesday, November 12, 2014 8:56 PM
  • @Carmine

    Yes, reattaching the mic array solves the problem. As I said, you can also simulate the issue by disabling the XBOX NUI Sensor driver in device manager while keeping mic array still connected.

    We do not need the mic array and we wanted to make space in our product. That is all. We've checked with 1408-PublicPreview and observed that there was no change in depth/infrared data.

    Wednesday, November 12, 2014 9:33 PM
  • Microsoft/To whom it may concern:

    After a few more tests, the combination between our hardware (Core i5) plus the current SDK (1409) does not provide the necessary stability to go further with a scheduled POC.  

    I feel very disappointed, that after 10 days after my initial post, there isn't an official position regarding the support of Kinect V2 on Core i5, although the product page (Microsoft Store/Requirements) still mentions Dual Core 2.66 as minimal requirement, leading more people to the possibility to have the product with an unsupported hardware.  

    Can someone (PLEASE) from Microsoft provide an official response to the following points: (asked before) 

    1) It will be possible (I'm asking if there are plans to fix) use Core i5 with Kinect V2, 100% or not ?

    2) If yes, when ? 

    3) Why is still advertised the Dual Core 2.66 ? Can a Dual Core 2.66 work 100% with a Kinect V2 ?

    Thank you,

    Pedro


    Pedro

    Wednesday, November 19, 2014 4:57 PM
  • Hello Pedro,

    I am not from Microsoft but I wanted to point out that we have tested Kinect V2 with 2 different i5 systems which work fine.

    In addition, we have also tested i3 NUC which was also fine. We have reduced our system to i3.

    Wednesday, November 19, 2014 6:51 PM
  • I updated the troubleshooting guide with additional steps to troubleshoot, this includes turning on the Intel SpeedStep in the BIOS and ensuring the Audio from the microphone is not disabled(hardware or through control panel)

    Carmine Sirignano - MSFT

    Wednesday, November 19, 2014 7:59 PM
  • Intel SpeedStep is already on.

    NUC Bios:

    Intel Dynamic Power Technology => Energy Efficient Performance

    Processor Power Efficiency Policy => High Performance


    Pedro

    Thursday, November 20, 2014 6:16 AM
  • Turn off SpeedStep, and any power savings setting that will throttle down the system to conserve power.

    Carmine Sirignano - MSFT


    Thursday, November 20, 2014 6:00 PM
  • As Carmine has mentioned before, don't work via Remote Desktop! We have used a far stronger Zotac box, and wanted to control it over RDP, but the system ran for a couple of secs, then stopped and started again (in a loop) ---

    Then we started the Kinect App the usual way, and it worked like a charm.

    Best,


    marher - dx

    Friday, November 21, 2014 7:44 AM
  • You can do RDP, but you have to remember to change the Audio redirection to "Play on Server"

    Carmine Sirignano - MSFT

    Friday, November 21, 2014 9:05 PM