locked
Azure App Service 1.3 installer on Azure Stack RRS feed

  • Question

  • I followed the instructions to install Azure app service 1.3 on ASDK.  I got to the point where I need to log onto SQL Server.  It fails to log into SQL server.  Event log on SQL server has the following message:

    Login failed for user 'admin'. Reason: An attempt to login using SQL authentication failed. Server is configured for Integrated authentication only

    I do have both integrated and SQL authentication enabled.  I can login with user ID 'admin' and password using SQL authentication from SQL Server Management Studio.

    I am using free developer edition of sql server 2017 running on windows 2016

    Attached are the screen shots from both Azure App Service and SQL Server Mngt Studio.

    https://social.msdn.microsoft.com/Forums/getfile/1311008 

    https://social.msdn.microsoft.com/Forums/getfile/1311010





    Hilalh



    Friday, August 31, 2018 3:05 AM

Answers

  • You can spin up a VM in same VNET to validate the SQL connectivity.

    AppService can be deployed to existing VNET, so having the public endpoint exposed is not mandatory.

    • Proposed as answer by Alok.Pagariya Saturday, September 1, 2018 12:28 AM
    • Marked as answer by Hilal Al-Hilali Saturday, September 1, 2018 12:42 AM
    Friday, August 31, 2018 10:43 PM
  • That solved the problem.  SQL Server has to be in the same vnet or sql connectivity has to be set to public.

    Also, as best practice configure sql server for sql authentication during setup in Azure portal instead of doing it afterwards through sql management studio


    Hilalh

    Saturday, September 1, 2018 12:26 AM

All replies

  • Hello,

    I’ve seen this error when attempting to pass an Null/Empty password to SQL Server. 

      

    Also, your SQL server is probably not joined to the AzureStack domain and as such, should be configured to use SQL authentication only.

     

    To change security authentication mode:

    • In SQL Server Management Studio Object Explorer, right-click the server, and then click Properties.
    • On the Security page, under Server authentication, select the new server authentication mode, and then click OK.
    • In the SQL Server Management Studio dialog box, click OK to acknowledge the requirement to restart SQL Server.

    To restart SQL Server from SQL Server Management Studio

    • In Object Explorer, right-click your server, and then click Restart. If SQL Server Agent is running, it must also be restarted.

       

    Let us know how it goes.

      

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with ASDK release, feel free to contact us.

         

     Thanks

     



    Gary Gallanes


    Friday, August 31, 2018 6:31 PM
  • Thanks for the reply.  As I mentioned SQL Server is configured to use both integrated and sql authentication.  There is no option to set it to SQL authentication ONLY.

    I did go into Azure portal and under SQL configuration there is an option SQL Authentication - it was marked disabled.  I changed it to enable.  Now I get an error in the SQL event log that says:

    Login failed for user 'username'. Reason: Could not find a login matching the name provided.

    Same user can log in from sql server management studio.


    Hilalh

    Friday, August 31, 2018 10:10 PM
  • From another environment create file with .udl extension and check if able to connect to SQL.
    Friday, August 31, 2018 10:20 PM
  • Thanks for the suggestion.

    I have tried connecting to SQL from another environment using SQL native client with the same error as above. I have sql connectivity set to private (within virtual network) and believe this needs to be set to public - but it appears I cannot do that once the VM is created so I am spinning up a new VM with the new configuration to try that.


    Hilalh

    Friday, August 31, 2018 10:37 PM
  • You can spin up a VM in same VNET to validate the SQL connectivity.

    AppService can be deployed to existing VNET, so having the public endpoint exposed is not mandatory.

    • Proposed as answer by Alok.Pagariya Saturday, September 1, 2018 12:28 AM
    • Marked as answer by Hilal Al-Hilali Saturday, September 1, 2018 12:42 AM
    Friday, August 31, 2018 10:43 PM
  • Good idea.  Thanks.

    Hilalh

    Friday, August 31, 2018 11:02 PM
  • That solved the problem.  SQL Server has to be in the same vnet or sql connectivity has to be set to public.

    Also, as best practice configure sql server for sql authentication during setup in Azure portal instead of doing it afterwards through sql management studio


    Hilalh

    Saturday, September 1, 2018 12:26 AM