none
IIS won't run after March 14 updates.

    Question

  • We have a problem with IIS, on all our existing WES2009 installtions.

    This started with Windows updates that were published on March 14.

    We have reason to believe KB4012204 was responsible.

    This IIS Admin service won't start, it fails with error code -2147418113 (hex 8000FFFF), or “Catastrophic Failure".

    We'd really appreciate some help with resolving this problem.

    We've tried uninstalling the updates, but this has not fixed the problem.

    Tuesday, April 11, 2017 11:22 AM

Answers

  • This turns out to have been a mistaken diagnosis.

    In fact, the cause was a domain policy change, which was made at about the same time.

    It turns out that if non-administrator users ('Interactive') are granted permission to start or stop the IIS admin service, then no-one (administrator or not) is able to start the IIS admin service. Consequently IIS won't run.

    This is a bug in IIS for XP, IMO.


    • Marked as answer by pheest Wednesday, April 19, 2017 11:51 AM
    Tuesday, April 18, 2017 8:43 AM

All replies

  • Since this is an update issue, please elevate the issue directly with Microsoft technical support to get faster response.

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Tuesday, April 11, 2017 2:13 PM
    Moderator
  • This turns out to have been a mistaken diagnosis.

    In fact, the cause was a domain policy change, which was made at about the same time.

    It turns out that if non-administrator users ('Interactive') are granted permission to start or stop the IIS admin service, then no-one (administrator or not) is able to start the IIS admin service. Consequently IIS won't run.

    This is a bug in IIS for XP, IMO.


    • Marked as answer by pheest Wednesday, April 19, 2017 11:51 AM
    Tuesday, April 18, 2017 8:43 AM