locked
Create Unit Test option is greyed out in my Visual Studio 2010 premium edition RRS feed

  • Question

  • Hi All,

    Unitll couple of days before, every thing was working and today "Create Unit Test" option in the schema view is greyed out. I have checked all the references and are in place properly. Any suggestions please?


    "Indian"

    Wednesday, September 26, 2012 8:26 AM

Answers

  • Hi Pranay,

    Thank you for posting in the MSDN forum.

    Maybe you could share us a screen shot about it. Just to make this issue clearly, do you mean that you couldn’t click the “Create Unit Tests” when you right click a class method?

    If so, whether all class methods have the same issue? If you have other environment, how about creating the test in another PC?

    As you said it worked well  in the same Environment before, I doubt that it is related to your VS, if possible, try to run the following steps in the command line.

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    After these, you can create a new project in a new workspace to avoid if there’re any problems of the old workspace settings, and then create a unit test for your class method. Check the result.

    If I have misunderstood anything, please make free feel to let me know.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, September 27, 2012 5:31 AM