none
Biztalk 2010 TCPIP adapter RRS feed

  • Question

  • Hi, Im devoloping a tcpip adapter form Biztalk server 2010 but I have an error that make my crazy, the error is:Excepcion al procesar mensajeSystem.Runtime.InteropServices.COMException (0xC0C01666): The Messaging Engine failed to register the adapter for "TCPIP" for the receive location "tcpip://10.181.34.123/5555". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.
       en Microsoft.BizTalk.TransportProxy.Interop.IBTTransportProxy.RegisterIsolatedReceiver(String url, IBTTransportConfig callback)
       en udi.sms.carm.es.RunTime.TCPIPReceiveAdapter.TCPIPReceiver.Init(String url)
       en udi.sms.carm.es.RunTime.TCPIPReceiveAdapter.TCPIPReceiver.ProcessRequest(TCPIPMsgContext msgContext, String fileName)

     

    I debug the code and the exception is throwed in the IBTTransportProxy.RegisterIsolatedReceiver method.

     

    The same code works fine for biztalk 2004, but in 2010 version doesn´t, I registered de adapter with a .reg file make by the adapter registry wizard.

    Thanks in advance for any idea.

     

    Friday, June 17, 2011 12:54 PM

Answers

All replies

  • In the BizTalk SDK samples there are some custom adapter .reg files. I would compare these with the generated .reg file and make sure it looks similar. Also, if you are on a 64-bit server, you have to register the adapter under the 64-bit registry too. Here is a link about how to do this: http://social.msdn.microsoft.com/Forums/en-US/biztalkgeneral/thread/ef3222de-d0c5-4881-aa67-0e50c4592b1a.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, June 20, 2011 4:53 PM
    Moderator
  • Thanks Ben but there isn´t exactly my problem, my adapter if it appears in the BiztalkAdministration, but when I try to send a message and submit to Biztalk I get the error "The Messaging Engine failed to register the adapter for "TCPIP" for the receive location........

     

    Thanks in advance for the help

    Friday, September 2, 2011 12:31 PM