locked
Setting up debugging in VS 2013 RRS feed

  • Question

  • Hello,

    PLEASE SEE NOTES TOWARD THE BOTTOM OF THE POST.  I may have solved this and as well may have located something that will save others loads of grief -- keeping the original post:

    ============================

    Original Post:

    I had VS 2013 preview installed, debugging modules (applications) for a Dot Net Nuke site was going fine.  The demo ran out, I bought the full version, supposedly settings are copied over, etc.  However, after attaching to the worker process I'm consistently getting hollow breakpoints.  The generic "Breakpoint will not currently be hit.  No symbols have been loaded for this document" shows up when one mouses over the point.

    This is a very long post so I'll add this -- I can debug the old fashioned way by changing the code, setting up a text box in a module, etc. to read exceptions or use the DNN event viewer.  The point is the code builds and it runs so the right paths of course are set up.  So there is a VERY obvious missing setting or as mentioned later, when the full version was bought some setting just wasn't copied over and finding it now will be a tough one.

    Configuration Manager modes for the project and site is set for debug in each.  As I was thinking about this, realized there's a web config setting for compilation mode and I set debug to true.  It was false ... Aha! ... I told myself but no, this didn't fix it.

    I found an article about setting Debug | Windows | Modules, checking the the box to see this window but ... nothing is in it.  I'm not sure this is applicable for web dev anyhow.

    I've made sure the App Pool and project .Net framework versions are correct.

    During build, if "Build website as part of solution" was checked, I would get 1 success and 1 failed as the final build message.  I unchecked it, I get "2 Succeeded now" and thought this may be it.  Nope ... hollow break points.

    I'm using a Windows 8.1 laptop, IIS8, SQL Express.  As mentioned, I've been doing fine until I upgraded to the full version so it appears some setting may not have copied over?

    In the Attach to Process dialog, I can find the worker process and attach with no issues, so it appears.  I have to always restart VS under a different account, then reattach to the process, then accept a warning as to what attaching to a process might do to my precious machine, etc.  But this was never a problem before.

    I could put up screen shots but I don't see where they would add clarity.  I use 2012 and 2013 at my day job with no issues as far as setting up IIS, etc.

    Looking for a lifeline here ... Thanks!

    End of first part of post

    ==============================================

    Edits as of 19:54 EST:

    ==============================================

    TOOK A LONG TIME TO FIND THIS ONE...

    ==============================================

    I put a similar post on Christoc's blog.  Continued looking and finally noted my compilation tag had the "batch="false"" attribute in it.  I did put this in, following a Scotty Gu post about a month ago and it fixed an issue.  Well, removing it fixed the above issue, read on ...

    Christoc,

    I've followed all the above on your posts.  Web config is set for debug = true, compilation drop down on the standard tool bar is Debug.  I can attach to the worker process, etc.  but can't set a break point that will be hit.

    The code has to be in the correct location because I can edit what I have in VS 2013 and the edits play out on local host.  (Scenic route to a Sanity Check)

    I have NO idea what is up.  Using a Toshiba laptop, Windows 8.1, IIS 8, VS 2013 with the most recent updates. (Note, VS 2013 Preview was doing fine ... should I contact Microsoft, tell them I'll take that version and they can keep the money? :) )

    I don't see how to insert images or I'd show the standard toolbar drop down for config manager, the web config entry and so on.  They're all correct.

    I found it but have no idea why this worked.  There is a post by Scott Gu, which I followed to correct a certain issue (I don't recall it) where in the compilation tag in the web config, one puts in the key and value of batch="false".   I found another post where a user put in the debug="true" and his compilation tag didn't have the batch="false" attribute.

    Well ... I removed this and sure enough the break point can now be set.  This is not the exact article I located but does mention the Scott Gu post: http://stackoverflow.com/questions/440675/compile-error-cs0433-on-pre-compiled-asp-net-2-0-site

    Is creating this attribute in the compilation tag now not a thing to do?  I forget the exact reason I set this up but it was only a month ago and it did fix an issue.


    Michael Durthaler



    • Edited by SACSgtMike Sunday, March 9, 2014 11:54 PM
    Sunday, March 9, 2014 10:35 PM

Answers

  • Hi,

    Welcome to MSDN.

    In order to solve your issue more efficiently and help the others who have similar issues, I would suggest you keep one issue in one of your threads, if you have the other issue, you could sepreate them to mulitiple threads.

    To get clear which issue do you want to get help, I would suggest you help us clarify the following information.

    1. What is your main issue in this thread? Is it one of the following issues?

    >>after attaching to the worker process I'm consistently getting hollow breakpoints.  The generic "Breakpoint will not currently be hit.  No symbols have been loaded for this document" <<

    • Do you mean that you got hollow breakpoints after you attaching to w3wp.exe process? If so, has it been solved now?

    >>Well ... I removed this and sure enough the break point can now be set.  This is not the exact article I located but does mention the Scott Gu post: http://stackoverflow.com/questions/440675/compile-error-cs0433-on-pre-compiled-asp-net-2-0-site <<

    • Do you mean that you could hit these breakpoints when attaching to w3wp.exe process after you removed the config setting batch=false? I found this document below which has the description for batch.

    Reference: compilation Element (ASP.NET Settings Schema)

    Optional Boolean attribute.

    Indicates whether batching is supported.

    If True, eliminates the delay caused by the compilation required when you access a file for the first time. When this attribute is set to True,ASP.NET precompiles all the uncompiled files in a batch mode, which causes an even longer delay the first time the files are compiled. However, after this initial delay, the compilation delay is eliminated on subsequent access of the file.

    The default is True.

    2. What is the type of your project? A website or a web application? Does it has any .ascx control? If you create a new simple sample, will it has the same issue?

    3. To make sure whether this issue is related to the other products, you could test it in another machine, if it has the same issue, it seems that this issue is related to your project which means that that changing config setting solved this issue indeed.

    If you got any screenshot, we appreciated that you could share it with us, since it is quite helpful to narrow down this issue.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Carl Cai Monday, March 10, 2014 7:42 AM
    • Marked as answer by Carl Cai Monday, March 17, 2014 1:38 AM
    Monday, March 10, 2014 7:41 AM