none
Symbols not loading "HTTP_STATUS_NOT_FOUND" RRS feed

  • Question

  • Hello all, I hope one of you can help me

    I'm getting a Symbol file not found error when I debug using WinDbg. I've tried setting the Symbol server as 

    srv*c:\symbols*https://msdl.microsoft.com/download/symbols

    Out put from WinDBG in Kernel mode: 

    Opened \\.\COM4
    Waiting to reconnect...
    Connected to Windows 10 14393 ARM (NT) Thumb-2 target at (Tue Mar 14 22:17:31.811 2017 (UTC + 0:00)), ptr64 FALSE
    Kernel Debugger connection established.
    Symbol search path is: srv*
    Executable search path is: 
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntkrnlmp.exe - 

    my raspi build is 

    10.0.14393.953

    my host machine build is

    14393

    *****this is a noisy output***

    ***note it gives me a 404 not found error message***

    0: kd> !sym noisy
    noisy mode - symbol prompts on
    0: kd> .reload
    Connected to Windows 10 14393 ARM (NT) Thumb-2 target at (Tue Mar 14 23:21:54.888 2017 (UTC + 0:00)), ptr64 FALSE
    SYMSRV:  c:\symbols\ntkrnlmp.pdb\5CEC372CE2CE406781DC98516FF5E0221\ntkrnlmp.pdb - file not found
    *** ERROR: HTTP_STATUS_NOT_FOUND
    *** ERROR: HTTP_STATUS_NOT_FOUND
    *** ERROR: HTTP_STATUS_NOT_FOUND
    SYMSRV:  c:\symbols\ntkrnlmp.pdb\5CEC372CE2CE406781DC98516FF5E0221\ntkrnlmp.pdb not found
    SYMSRV:  https://msdl.microsoft.com/download/symbols/ntkrnlmp.pdb/5CEC372CE2CE406781DC98516FF5E0221/ntkrnlmp.pdb not found
    DBGHELP: ntkrnlmp.pdb - file not found
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntkrnlmp.exe - 
    DBGHELP: nt - export symbols
    Loading Kernel Symbols

    ...............................................................
    ................................................................
    .....
    Loading User Symbols

    Loading unloaded module list
    .......

    ************* Symbol Loading Error Summary **************
    Module name            Error
    ntkrnlmp               The system cannot find the file specified
    The SYMSRV client failed to find a file in the UNC store, or there
    is an invalid UNC store (an invalid path or the pingme.txt file is
    not present in the root directory), or the file is present in the
    symbol server exclusion list.

    Please help!!

    Wednesday, March 15, 2017 12:04 AM

All replies