locked
Custom Editform.aspx, cannot add attachments to existing list items. RRS feed

  • Question

  • I have a custom editform.aspx for a sharepoint list (MOSS 2007).  There is no additional code added, my only changes were cosmetic (spaces between sections, changed fill colors, et al).  I have been using this custom form for a couple of years, and have made edits before with no issues.  However, after making my most recent change (10/31), I can no longer add attachments to list items that already exist.  I CAN create a new list item, save it, re-open, add an attachment and save this newly created list item, but when I try to add attachments to existing items, hitting the OK button does nothing (the page blinks then I'm still on the same edit screen without my attachment).

    I know about the idAttachmentsRow issue, and have double checked to make sure generate-id is not present.  I'm baffled, and this list is highly visible and used often.  Please advise. 


    paul truland

    Tuesday, November 5, 2013 4:45 PM

All replies

  • Hi paul,

    I couldn't reproduce this issue.

    As you mentioned you have checked the idAttachmentsRow issue, may need to check again.

    Please check if all users have this issue, and if all types of browsers have this issue.

    Please check if the original OOB editform.aspx and another newly created custom editform.aspx still have this issue for that list.

    And you can also check if there are some ULS log error when you add the attachment for existing item.

    Thanks,
    Daniel Yang
    Forum Support
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, November 6, 2013 10:05 AM
    Moderator
  • Thanks Daniel.  I doubled checked and idAttachmentsRow is NOT present.  I restored the original EditForm.aspx, and still could not attach.  I tried a new editform from scratch, that didn’t work either.  I cannot check the ULS logs, as I’m not granted that level of access (I've requested my farm host to review, I'll reply with his answer).  Any other ideas?  This list also has lots of workflows, so creating a new list and moving the items is not an option. 

    Wednesday, November 6, 2013 6:09 PM
  • More to add...I just tried to see if I could edit the item at all, and I cannot.  Even without trying to attach anything, If I edit the item and hit OK, it does nothing; page blinks then I'm still in the edit page. 
    Wednesday, November 6, 2013 6:13 PM