none
Computer is having problems to install Net v4 and Microsoft Office 2010. RRS feed

  • Question

  • We bought an Acer PC a year ago, runs Windows 7 64 bit, and I downloaded some programs that I use, some help me with my Youtube videos and school work. Programs such as Handbrake worked and such. Then in October of this year, I bought the Office Home and Student 2010 product key card, because I need office for my schoolwork. it didn't work. It wouldn't install at all, I have tried everything, I googled solutions, and even though it worked for the person who asked, it still didn't work for me. One of the solutions was to do some stuff, and I believe in the process, some of the net frameworks were deleted. So one day I had to used Handbrake, but it said I needed to install the net framework version 4. I downloaded it and started to install, but I got an error and it didn't work. Lately, my computer get errors for everything that I want to download or whatever. Can you guys help me solve this problem, what is my computer missing to install the  Net framework v4 and Microsoft Office? I also get errors when trying to turn on my firewall, so I use solutions on the internet but I have to download something, and it doesn't work. i don't want to spend hundreds of dollars on fixing this problem. Microsoft Fixit also doesn't work on my computer, I get errors for that too! I can still continue doing work but I don't know why my computer is restricting many things!

    Is Microsoft Office not installing because I don't have net framework v4??

    Microsoft error: Microsoft Home and Student 2010 encountered an error.

    Net Framework 4 error says: The specified service does not exist as an installed service

    Net Framework log file:

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = C:\242d6a0c598a9afc8b9a97312d\\Setup.exe /x86 /x64
    TimeZone = Eastern Standard Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 11
    Exe (C:\242d6a0c598a9afc8b9a97312d\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\242d6a0c598a9afc8b9a97312d\Windows6.1-KB958488-v6001-x64.msu) failed with 0x424 - The specified service does not exist as an installed service. .
    Final Result: Installation failed with error code: (0x00000424), "The specified service does not exist as an installed service. " (Elapsed time: 0 00:00:11).

    Firewall error to turn on and use recommended settings: 

    Windows Firewall can't change some of your settings. Error code 0x80070424

    Thursday, December 27, 2012 8:39 PM

Answers

  • In this forum, we can address your .NET Framework 4.0 issue.

    The error message "The specified service does not exist as an installed service." indicates that your Windows Update is not working correctly (which, BTW, may be why you are having issues installing other software, like Office).

    For best help with Windows Update issues in Windows 7, please post in this forum:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update?tm=1356648338702

    Once you have addressed your Windows Update issues, here are steps to follow to install .NET Framework 4.0:

    Follow ALL these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    The complete log set is needed for analysis.

    • Edited by pvdg42 Thursday, December 27, 2012 10:48 PM
    • Marked as answer by Barry WangModerator Friday, January 4, 2013 7:54 AM
    Thursday, December 27, 2012 10:45 PM