none
My Windows 8 PC cannot detect my attached DVD/CD ROM RRS feed

  • Question

  • I have newly installed Windows Developer Preview on my PC. Previously it was running Windows XP. After installation my DVD/CD ROM Drive is not accessible. My PC is not showing any CD/DVD ROMs connected to it.
    Sunday, October 2, 2011 10:51 AM

All replies

  • I have the same question as it is not seeing my CD/DVD/Blu-Ray Drive. However, I did find a post on a site that said Windows 8 would go away from DVD-Rom Support (http://www.windows8news.com/2011/08/06/windows-8-ditch-dvd-support/). I don't know how true that is or not. Simply put, This is a pre-alpha release and drivers are probably not at the top of the list for extra items int he release.

    In short, I do not know if It will ever be a part of the Win8 OS or not. Though I would point out to Microsoft that it would be incredibly stupid to do so as many of the reasons people get a PC come on CD/DVD-Rom (Games, Music, etc.). You could try to go the the website of your cd-rom's manufacturer and download the latest drivers (use Win7 ones, as I'm sure Win8 Drivers are limited, if they exist at all). Install them, if it lets you, and hope for the best. If it works, you have your CD-Rom back... if not.. you will have to uninstall Windows 8 and re-install Windows 7. There is a step-b-step guide at http://pureinfotech.com/2011/10/10/how-to-uninstall-windows-8-developer-preview-and-restore-windows-7-step-by-step/ on how to do this.

    Good luck. I hope you find an answer as I think it would be suicide for Microsoft to leave out DVD-Rom support and I other than this one HUGE problem, most other issues are small and expected for a pre-alpha release.


    There are 10 types of people in the world; those that understand binary, and those that don't.
    Wednesday, October 12, 2011 5:20 PM
  • if its not detected you can find the solution in this site...

    How to show up DVD/CD ROM in windows 8 if not detected

    i hope this will help you

    • Edited by saldriass Saturday, March 17, 2012 8:23 PM
    Saturday, March 17, 2012 8:22 PM
  • Right click Computer on desktop then go to Properties> Device manager>IDE ATA/ATAPI controllers

    Uninstall Standard Dual Channel PCI IDE Controller. A message will appear that you need to restart your compter. Press No and scan for hardware changes. Restart your PC now and i hope next time when windows will start you will be able to see your DVD ROM!

    • Proposed as answer by YourANGEL31 Friday, December 14, 2012 11:52 AM
    Wednesday, December 5, 2012 5:22 PM
  • Your the best. Thanks alot
    Friday, December 14, 2012 12:04 PM
  • That was the perfect fix thank you
    Thursday, December 20, 2012 11:38 PM
  • Thanks, Superb answer.
    Sunday, December 30, 2012 10:04 AM
  • brO.. you are awesom3 ... !!!! (Y)
    Wednesday, January 9, 2013 3:11 PM
  • You're a Star!

    Saturday, January 26, 2013 12:34 PM
  • Thank you.....I read and tried the others for this fault, and YOUR'S did it  for me..

    Funny thing is I am PC savvy, but at my age I tent to forget the obvious little things, normally I would have easily known this, but, guess what?

    Thank you again for jolting my memory.

    Ta mate!

    Tuesday, July 16, 2013 3:02 PM
  • I tried yours but registry did not have the "extra" extensions in windows 8?...see below!

    2. In the Command Prompt Window just type & enter 
    reg.exe add "HKLM\System\CurrentControlSet\Services\atapi.....>>>did not have in my registry?>>>\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001.....

    But found fix for problem far easier ....uninstalled..>>Standard Dual Channel PCI IDE Controllers...done!

    cheers!

    Tuesday, July 16, 2013 3:08 PM
  • I have the same problem with DVD/CD ROM Drive in Windows 8. Uninstall Standard Dual Channel PCI IDE Controller works great. Thanks!
    Wednesday, August 21, 2013 5:38 AM
  • Thank's so much, Great answer
    Friday, November 1, 2013 12:37 PM
  • You're a GOD MAN !!!!!!  Thanks Very much !!!

    Thursday, November 21, 2013 2:55 AM
  • you are awesome man......  it is very easy and perfect.....
    Monday, April 28, 2014 4:50 AM