none
SQL Server 2016 Express Basic installation error

    Question

  • I.m trying to install Sql Server 2016 Express basic on my laptop (windows 10). At the end of installation I got an error : trying to perform a not-authorized process.

    The detail file from the log has the following error :

    The configuration failure category of current exception is ConfigurationFailure
    Configuration action failed for feature SQL_Engine_Core_Inst during timing ConfigNonRC and scenario ConfigNonRC.

    I started the installation as an administrator and I disabled the firewall, but the installation still  fails.  I suppose I have to change something in my configuration, but I don't know what to do.

    Best regards,

    Thijs

    Thursday, February 02, 2017 8:21 PM

All replies

  • Hello,

    Please share with us the Summary.txt log file. The following article may help you locate the file.

    https://msdn.microsoft.com/en-us/library/ms143702(v=sql.130).aspx


    If you can upload the whole set of setup files to your Public folder on OneDrive (for example) and share the URL with us, then even better.



    Thanks in advance.



    Regards,

    Alberto Morillo
    SQLCoffee.com


    Thursday, February 02, 2017 8:33 PM
    Moderator
  • Thank you for your quick reply.

    This is the link to the log file : https://1drv.ms/f/s!AhQfq0VgBOJZhL49B4utgAN3nOYWzQ

    Best regards,
    Thijs

    Thursday, February 02, 2017 9:00 PM
  • Hello,

    Thank you for your patience while I was examining the logs.

    It seems this issue is related to permissions SQL Server setup needs to access registry keys like:

    (01) 2017-02-02 11:03:33 Slp:     Inner exception type: System.UnauthorizedAccessException

    (01) 2017-02-02 11:03:33 Slp:         Message:

    (01) 2017-02-02 11:03:33 Slp:                 Poging tot het uitvoeren van een niet-gemachtigde bewerking.

    (01) 2017-02-02 11:03:33 Slp:         HResult : 0x80070005

    (01) 2017-02-02 11:03:33 Slp:         Stack:

    (01) 2017-02-02 11:03:33 Slp:                 bij Microsoft.SqlServer.Configuration.Sco.InternalRegistryKey.OpenSubKey(String subkey, RegistryAccess requestedAccess)

    (01) 2017-02-02 11:03:33 Slp: Watson Bucket 1

     Original Parameter Values

    (01) 2017-02-02 11:03:33 Slp: Parameter 0 : SQL Server 2016@RTM@

    (01) 2017-02-02 11:03:33 Slp: Parameter 1 : Microsoft.SqlServer.Configuration.Sco.InternalRegistryKey.OpenSubKey

    (01) 2017-02-02 11:03:33 Slp: Parameter 2 : Microsoft.SqlServer.Configuration.Sco.InternalRegistryKey.OpenSubKey

    (01) 2017-02-02 11:03:33 Slp: Parameter 3 : Microsoft.SqlServer.Configuration.Sco.ScoException@1211@1

    (01) 2017-02-02 11:03:33 Slp: Parameter 4 : System.UnauthorizedAccessException@-2147024891

    (01) 2017-02-02 11:03:33 Slp: Parameter 5 : SqlEngineConfigAction_install_confignonrc

    (01) 2017-02-02 11:03:33 Slp: Parameter 6 : INSTALL@CONFIGNONRC@SQL_ENGINE_CORE_INST

    (01) 2017-02-02 11:03:33 Slp: Parameter 7 : HKEY_LOCAL_MACHINE@SYSTEM\CurrentControlSet\Services\FltMgr

    (01) 2017-02-02 11:03:33 Slp: Parameter 8 : HKEY_LOCAL_MACHINE@SYSTEM\CurrentControlSet\Services\FltMgr

    Another error of this kind.


    The subkey '{5B860485-0F07-41DC-BA8C-3A839A141FBA}' under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall cannot be opened for Read, skip it.



    Please provide full control access to the Windows account used to install SQL Server. Use Local System for the SQL Server service account instead of the default provided by SQL Server setup, and disable any security software that may be blocking access to the registry keys.



    Hope this helps.



    Regards,

    Alberto Morillo
    SQLCoffee.com



    Thursday, February 02, 2017 10:17 PM
    Moderator
  • Hi,

    Thanks for your reply.

    I use a administrator account, and disabled all security.
    You said 'Use Local System for the SQL Server service account instead of the default provided by SQL Server.'
    How can I change that?

    I did a file check, there were no errors.

    Installation still fails.

    Regards,

    Thijs


    Friday, February 03, 2017 12:28 AM
  • Hello,

    Regarding your question, please change the service account to Local System on the Server Configuration page of SQL Server setup as shown on below article:

    http://www.sqlcoffee.com/SQLServer2016_0001.htm

    Assign full control permissions on the registry keys to System and to the Windows account running SQL setup.

    http://techlogon.com/2012/11/26/how-to-change-permissions-of-a-registry-key/



    Hope this helps.



    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, February 03, 2017 1:23 AM
    Moderator
  • Hi,

    Still no succes. I tried to change the owner of the register key FltMgr. The owner is SYSTEM.  Problem is that when I changed it, I got an access denied error. So this is also the problem with the installation.

    Do you know a way to change SYSTEM to the administrator?

    Regards,
    Thijs

    Friday, February 03, 2017 7:35 PM
  • Hello,

    Take ownership of the key, but leave System permissions please.

    http://ccm.net/faq/45190-how-to-take-ownership-of-a-registry-key-in-windows-10



    Hope this helps.



    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, February 03, 2017 8:29 PM
    Moderator
  • Hi,

    Ownership is set to administrators (I did this in safemode), but I still got the same error. I tried to add my user account, this was not possible in normal mode.

    Is it possible to install SQL Server Express in safe mode (with network)?

    Regards,
    Thijs

    Friday, February 03, 2017 8:50 PM
  • Hello,

    Try to enable the Administrator account, log in to Windows using that account and install SQL Server with it.

    http://www.intowindows.com/enable-the-hidden-administrator-account-in-windows-10/



    Hope this helps.



    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, February 03, 2017 11:49 PM
    Moderator
  • Hi,

    I enabled and used the hidden administator account, but got the same error, perform unauthorized action.

    Best regards,

    Thijs

    Saturday, February 04, 2017 1:04 AM
  • Hi,

    I enabled and used the hidden administator account, but got the same error, perform unauthorized action.

    Best regards,

    Thijs

    I can see you have installed many instances of SQL express 2016, I believe it is 6 instances do you really need those instances. I am not sure whether they are in working state or not. Anyways I find below in logs

    (01) 2017-02-02 11:03:33 SQLEngine: --RsFxConfiguration: Service RsFx0410 does not exist, executing install steps

    And i believe this is the reason for the failure. Unfortunately I do not know how to resolve this missing this so I searched and found reply by Teige Gao from this thread

    You can also refer to this blog for fixing the issue

    1.    This file does not exist, please go to C:\Program Files\Microsoft SQL Server\130\Shared\RsFxInstall to check it, if it is not there, please use the following steps:

    a.    Use CMD, change dictionary to the setup.exe, then use the following code:

    setup /q /action=uninstall /instanceid=MSSQLSERVER /features=SQLEngine,Replication,FullText

    b.    Now, run rsfx.msi file from ..\Installation folder\[x64]\Setup folder. This will create the RsFxInstall folder and .ini files.

    If this file exists, please refer to the following scenario.

    2.    Please grant the account you used to install SQL Server Full Control permission on C:\Program Files\Microsoft SQL Server folder and all subfolders, including C:\Program Files\Microsoft SQL Server\130\Shared\RsFxInstall\RsFx0401.inf.

    3.    A system or domain policy removing the SeDebugPrivelege security privilege from the administrator account running setup, please open Group Policy to check it:

    a.    Start run,  then type gpedit.msc, go to Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Debug programs.
    b.    The account through which we are trying to run the setup should be there

    If this does not helps I believe you have uninstall things completely and start a fresh install


    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP


    Saturday, February 04, 2017 5:55 AM
    Moderator
  • Hello

    I have what seems to be the same problem as you, Thijs, when trying to install SQL Server Express 2016.  At the end of the installation the message appeared that it did not have the required permission to configure the database engine ("SqlEngineConfigAction_install_configonrc_cpu64" ) and then failed to install both the database engine and the reporting services.  In an attempt to overcome this problem I tried two earlier versions of SQL Server Express - 2014 and 2012 but got exactly the same error message towards the end of the installation.  On one attempt I disabled Norton firewall and virus checker with internet access switched off, but this made no difference, so it does not look like a firewall issue. At the end of 2013 I had no problem at all installing SQL Server 2012 Express with Advanced Services on my old Windows 7 machine, which has since successfully migrated to Windows 10 64bit.  However when I tried to install the same version of SQL Server Express 2012 directly onto a new Windows 10 Pro 64bit machine, I got the same error message as you.

    Each time the installation failed I went back to a restore point setup just prior to starting the installation. Eventually, for some reason - whether due to the rolling back to the restore point or not I do not know - my antivirus software Norton 360 started complaining, and failed to operate.  I then found I was unable to reinstall Norton 360 and have spent most of today being helped by two Norton technicians who eventually got Norton working again.   I mention this because each time Norton failed to install (which was several times) it came up with similar error message to those encountered with SQL Server Express installation - Norton 360 could not gain the required permissions to complete its installation.  The Norton technician remarked that there appeared to be a component of the Windows 10 operating system which was not granting the required permission to install the Norton software.  This also sounds like a good description of the problem with the SQL Server installation.  Incidentally the Norton problem was not caused by any viruses - none were found.

    I am just wondering whether there is some bug in the Windows 10 operating system which may be preventing some applications from installing and which Microsoft need to sort out. 

    I would be interested to hear if anyone has any thoughts on this, or if any other visitors to this thread have this "permission" issue too.

    Regards

    Richard

    Saturday, February 11, 2017 1:09 AM
  • Hello Richard,

    Thank you for your reply. This looks like the same problem. Do you know which windows component caused the error?

    Regards,

    Thijs

    Wednesday, February 22, 2017 2:03 PM
  • Hello Shashank,

    The problem is that the installation program is not authorized to write to the fltmgr in the register. I tried to change something in the fltmgr logged on as the hidden administrator, but I also got the message that it is not possible to write to the fltmgr. Richard gave an answer that there is probably a windows 10 component which prevents to write to the fltmgr. In safe mode it is  possible to change something in the fltmgr, so it looks like the cause of the install problem has to do with a windows component. 

    Is it possible to check which windows component it concerns?

    Best regards,

    btw sorry for my late reaction, I was unable to reply before.

    Wednesday, February 22, 2017 2:13 PM
  • Hello Shashank,

    The problem is that the installation program is not authorized to write to the fltmgr in the register. I tried to change something in the fltmgr logged on as the hidden administrator, but I also got the message that it is not possible to write to the fltmgr. Richard gave an answer that there is probably a windows 10 component which prevents to write to the fltmgr. In safe mode it is  possible to change something in the fltmgr, so it looks like the cause of the install problem has to do with a windows component. 

    Is it possible to check which windows component it concerns?

    Best regards,

    btw sorry for my late reaction, I was unable to reply before.


    I am sorry my knowledge is limited in terms of windows 10. I agree it is not the best OS and has lot of drawbacks

    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP

    Wednesday, February 22, 2017 2:44 PM
    Moderator
  • Thijs

    At the moment I have no idea which part of the Windows 10 operating system refused to grant permission to install the database engine.   When the Norton technicians could not install Norton 360 on my Windows 10 operating system they circumvented the security issues by booting my computer in Safe Mode - that silenced whatever was causing the security objections and got the antivirus installed.  You could try the same thing with SQL Server Express and see if it works, perhaps. 

    I have eventually got SQL Server working, but by a circuitous and convoluted route.  Microsoft have recently published a pre-release version of SQL Server for Linux.  It installed and worked very nicely within a guest virtual Ubuntu machine created using Oracle VirtualBox on my Windows 10 operating system.  It can be accessed via the normal SQL Server Management Studio running on the Windows 10 host just as though it was installed in Windows. Not what I intended, but it does work! 

    Best regards

    Richard

    Friday, March 24, 2017 11:44 PM
  • Hello Thijs,
      I seem to have the same problem with installing SQL Server 2016.
      Did you find a solution meanwhile ?
      Thanks.

    Regards,
    Michel

    Friday, September 08, 2017 11:42 AM