locked
Error when trying to create Microsoft Project Site RRS feed

  • Question

  • We are receiving the following error when trying to create a project site. Dependency feature DeliverablesList for feature PWS is not activated at this scope. We have checked and tried to manually activate the DeliverablesList and we received the message that it was already activated for the whole site. The logs show the following messages. Sharepoint 2010

    10/18/2010 17:09:50.42 	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	Logging Correlation Data   	xmnv	Medium 	Name=Request (POST:http://intranet:80/dept/it/ns/ds/_layouts/AddGallery.aspx)	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.43 	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	Logging Correlation Data   	xmnv	Medium 	Site=/dept/it	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.54 	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	General            	8kh7	High  	There is no Web named "/dept/it/ns/ds/projects".	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.54 	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	General            	8e2r	Medium 	Possible mismatch between the reported error with code = 0x81070504 and message: "There is no Web named "/dept/it/ns/ds/projects"." and the returned error with code 0x80070002.	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.54 	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	General            	8e2s	Medium 	Unknown SPRequest error occurred. More information: 0x80070002	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.56 	w3wp.exe (0x277C)   0x164C	SharePoint Foundation     	Topology           	e5mc	Medium 	WcfSendRequest: RemoteAddress: 'http://mossapp1:32843/f7b1b5a1065946118c27439bc1822a10/ProfilePropertyService.svc' Channel: 'Microsoft.Office.Server.UserProfiles.IProfilePropertyService' Action: 'http://Microsoft.Office.Server.UserProfiles/GetProfileProperties' MessageId: 'urn:uuid:21bd1b36-b06d-4906-bc94-c4740b72d14c'	 
    10/18/2010 17:09:50.56 	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	General            	90hv	Unexpected	Detected use of SPRequest for previously closed SPWeb object. Please close SPWeb objects when you are done with all objects obtained from them, but not before. Stack trace:  at Microsoft.SharePoint.WebControls.ScriptLink.SharePointClientJs_Register(Page page)   at Microsoft.SharePoint.WebControls.ScriptLink.InitJs_Register(Page page)   at Microsoft.SharePoint.WebControls.ScriptLink.RegisterForControl(Control ctrl, Page page, String name, Boolean localizable, Boolean defer, Boolean loadAfterUI, String language)   at Microsoft.SharePoint.WebControls.ScriptLink.Register(Page page, String name, Boolean localizable, Boolean defer, Boolean loadAfterUI, String language, String uiVersion)   at Microsoft.SharePoint.WebControls.ScriptLink.RegisterOnDemand(Page page, String strKey, String...	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.56*	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	General            	90hv	Unexpected	... strFile, Boolean localizable)   at Microsoft.SharePoint.WebControls.ScriptLink.RegisterCore(Page page, Boolean defer)   at Microsoft.SharePoint.WebPartPages.SPWebPartManager.RegisterOWSScript(Page page, SPWeb web)   at Microsoft.SharePoint.WebPartPages.WebPartPage.FormOnLoad(Object sender, EventArgs e)   at System.Web.UI.Control.OnLoad(EventArgs e)   at System.Web.UI.Control.LoadRecursive()   at System.Web.UI.Control.LoadRecursive()   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)   at System.Web.UI.Page.ProcessRequest()   at System.Web.UI.Page.ProcessRequest(HttpContext context)   a...	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.56*	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	General            	90hv	Unexpected	...t ASP._layouts_addgallery_aspx.ProcessRequest(HttpContext context)   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)   at System.Web.HttpApplication.PipelineStepManager.ResumeSteps(Exception error)   at System.Web.HttpApplication.BeginProcessRequestNotification(HttpContext context, AsyncCallback cb)   at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotifica...	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.56*	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	General            	90hv	Unexpected	...tion(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags) 	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    10/18/2010 17:09:50.57 	w3wp.exe (0x20C8)   0x2FF0	SharePoint Foundation     	Topology           	e5mb	Medium 	WcfReceiveRequest: LocalAddress: 'http://mossapp1:32843/f7b1b5a1065946118c27439bc1822a10/ProfilePropertyService.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://Microsoft.Office.Server.UserProfiles/GetProfileProperties' MessageId: 'urn:uuid:21bd1b36-b06d-4906-bc94-c4740b72d14c'	441cbee1-f710-4c45-8028-e9a148db5d0f
    10/18/2010 17:09:50.57 	w3wp.exe (0x20C8)   0x2FF0	SharePoint Foundation     	Monitoring          	nasq	Medium 	Entering monitored scope (ExecuteWcfServerOperation)	441cbee1-f710-4c45-8028-e9a148db5d0f
    10/18/2010 17:09:50.63 	w3wp.exe (0x277C)   0x0A0C	SharePoint Foundation     	Fields            	88y1	Medium 	No document templates uploaded for list "$Resources:core,MasterPageGallery;" -- none found for list template "100".	0bf7181e-4b1c-4e57-b60c-8afa8dc7974f
    

    Monday, October 18, 2010 10:20 PM

Answers

  • Turns out that we had upgraded to Sharepoint 2010 and we found out that this is not supported. The recommended practice is to build a new Sharepoint 2010 farm and migrate all data to the new farm. This solved our issues with Project Server.
    • Marked as answer by Wolfraider Wednesday, April 25, 2012 2:57 PM
    Wednesday, April 25, 2012 2:57 PM

All replies

  • Hello Wolfradier,

    Can you provide more details as to how you where creating the project site.  How did you get to this point.... Have you been able to create sites before.. IS this a new deployment?    Etc.

    Cheers


    Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA
    www.WhartonComputer.com
    Tuesday, October 19, 2010 11:12 AM
  • We have created other kinds of sites with success. This is our first project site. Our sharepoint environment has been running for almost a year and has been upgraded to 2010 from 2007. I went to my department site within sharepoint and click create a new site, selected Microsoft Project Site, typed in a name and clicked create. Boom, error happens.
    Tuesday, October 19, 2010 1:53 PM
  • Just to be clear, so you have installed and configured project server 2010 and when you publish the project, the project workspace is not getting created?

    It should like you are using Sharepoint and creating a project workspace using one of the SharePoint templates.  You aren't doing this are you?

    Cheers


    Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA
    www.WhartonComputer.com
    Wednesday, October 20, 2010 6:54 AM
  • I am having exactly the same issue, and connot for the life of me work out how to get it working. We migrated from SharePoint 2007 and Project Server 2007 to 2010. When I go to create a new Project Site from MS Project professional the job fails and throws the same errors as listed in this post. Any ideas on how to fix it.


    Andrew Cooper - Deakin University

    I am seeing this issues in the PWA I noticed that the site name "WST" is repeated in the URL. I have bolded this. below...

    reateWssSiteContent: Creating project site failed! Project Uid=43b0e3a3-0721-42b3-9296-57ba508eba82, site URL=http://dpp-web-dev-1:83/PWA/WST, site name=WST. CreateSPWeb: Creating of web http://dpp-web-dev-1:83/PWA/WST failed. Wss reported error System.ArgumentException: File or arguments not valid for site template _{FE48E539-4CF0-48CA-BFEB-049FF33257B6}#st_. Parameter name: WebTemplate at Microsoft.SharePoint.SPWebTemplateCollection.get_Item(String strKey) at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate) at Microsoft.SharePoint.SPSite.CreateWeb(String strUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid webId, Guid rootFolderId, Boolean createSystemCatalogs) at Microsoft.SharePoint.SPSite.SPWebCollectionProvider.CreateWeb(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere) at Microsoft.SharePoint.SPWebCollection.Add(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean useUniquePermissions, Boolean bConvertIfThere) at Microsoft.Office.Project.Server.BusinessLayer.Admin.CreateSPWeb(SPSite topSite, String spWebUrl, String spWebName, String spWebDescription, String spWebLogoUrl, Int32 webTemplateLCID, String webTemplateName, String& errorMessage). Inner exception: [null]:
    • WSSCreateSiteFailure (16400). Details: id='16400' name='WSSCreateSiteFailure' uid='f2a62f22-a7c7-43f6-8f8f-fe12e6b90ba5' projectUID='43b0e3a3-0721-42b3-9296-57ba508eba82' workspaceUrl='http://dpp-web-dev-1:83/PWA/WST/WST' projectWorkspaceName='WST'.
  • Queue:
    • GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='01a5ade1-dbe8-46c8-aafa-0e0ebf76e384' JobUID='fbd8c7dc-0788-4394-bc77-fd44488de073' ComputerName='DPP-APP-DEV-1' GroupType='CreateWssSite' MessageType='CreateWssSiteMessage' MessageId='1' Stage=''. For more details, check the ULS logs on machine DPP-APP-DEV-1 for entries with JobUID fbd8c7dc-0788-4394-bc77-fd44488de073.
  • Edited by andrew13 Friday, April 20, 2012 1:34 AM
Friday, April 20, 2012 1:19 AM
  • Turns out that we had upgraded to Sharepoint 2010 and we found out that this is not supported. The recommended practice is to build a new Sharepoint 2010 farm and migrate all data to the new farm. This solved our issues with Project Server.
    • Marked as answer by Wolfraider Wednesday, April 25, 2012 2:57 PM
    Wednesday, April 25, 2012 2:57 PM