none
VS 2015 Pro - User profile issue with stale license

    Question

  • NOTE: This is a continuation of this post. Turns out that the issue wasn't to do with the license so I had to move it to this forum.


    I have been using VS 2015 Professional on my current system for almost a year now without any issues. Last month I got the usual message about a stale license. When I clicked to refresh it, nothing happened. Here is a summary of what I have tried since:

    • Discovered that if I removed my account, restart VS & readded the account then I get a network error the first time and then nothing on other attempts to refresh the license.
    • ActivityLog contained the following errors:
    Error - ClientRights - Setting client rights token from Server for IdeUser failed, Exception: The data is invalid. ...
    Warning - VisualStudio - License validation task failed unexpectedly. The application will be shutdown.
    
    See the link at the top of this posting for a stack trace.
    • Registry workaround for a domain account issue (see here) - I still have this in place
    • Tried creating a local account & found that VS works fine
    • Uninstalled all VS versions (2013 & 2015)
    • Reinstalled VS 2015 Pro with Update 3 --> no change
    • Tried /safemode --> crashed VS
    • Tried /resetuserdata & /resetsettings separately --> no change
    • Tried /uninstall /force, renamed the 14.0 VS folder in AppSettings\Local & Roaming and then reinstalled --> no change

    All this has done is to prevent me from using SSMS. It is now telling me to start VS to setup the cache. At least it can't get much worse now as all of my main apps don't work now.

    Does anyone have any other ideas because I am fresh out, short of reformatting the entire system which will be difficult as I work from home & my company laptop doesn't even have a disc drive ... not that I have any recovery media for this system.


    • Edited by Force42 Friday, April 21, 2017 3:20 PM made the first link clickable
    Friday, April 21, 2017 3:19 PM

Answers

  • Hi Joyce,

    It seems that you are not understanding, the license & VS works fine on my laptop when I created a new local user. The only time it doesn't work is when I login to Windows using my domain account; which is what I am needing.

    So something in VS is either no longer liking my domain account or something in my VS user setup is wonky. I have tried everything I could find on how to reset VS, including a full reinstall with no success. In fact things now worse as I can no longer use SSMS.

    Can you help or is their another forum that I should be using instead?

    UPDATE

    Well I have finally found the solution. Last year when I was setup with VS 2015, we couldn't get it to work with my domain account like everyone else, but my hotmail account worked fine as my VS account so we went with that.

    For some reason now, my hotmail account won't work when I am logged into Windows with a domain account & now my domain account is suddenly working fine as my VS account.

    • Edited by Force42 Monday, April 24, 2017 4:54 PM added found solution
    • Marked as answer by Force42 Monday, April 24, 2017 4:54 PM
    Monday, April 24, 2017 1:50 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    >>Tried creating a local account & found that VS works fine

    It turns out your visual studio professional 2015 is good.

    >>we have a MSDN subscription with more than enough licenses for our development teams. Our subscription comes with a digital license, rather than a key.

    Please call 1-800-426-9400, Monday through Friday, 6:00 A.M. to 6:00 P.M. (Pacific Time) to speak directly to a Microsoft licensing specialist, to make sure the license is valid.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 24, 2017 8:10 AM
  • Hi Joyce,

    It seems that you are not understanding, the license & VS works fine on my laptop when I created a new local user. The only time it doesn't work is when I login to Windows using my domain account; which is what I am needing.

    So something in VS is either no longer liking my domain account or something in my VS user setup is wonky. I have tried everything I could find on how to reset VS, including a full reinstall with no success. In fact things now worse as I can no longer use SSMS.

    Can you help or is their another forum that I should be using instead?

    UPDATE

    Well I have finally found the solution. Last year when I was setup with VS 2015, we couldn't get it to work with my domain account like everyone else, but my hotmail account worked fine as my VS account so we went with that.

    For some reason now, my hotmail account won't work when I am logged into Windows with a domain account & now my domain account is suddenly working fine as my VS account.

    • Edited by Force42 Monday, April 24, 2017 4:54 PM added found solution
    • Marked as answer by Force42 Monday, April 24, 2017 4:54 PM
    Monday, April 24, 2017 1:50 PM