locked
Installation of Visual Studio 11 on Windows 7 failed RRS feed

  • Question

  • I downloaded Visual Studio 11 Developer Preview on MSDN and dried installing it on my Windows 7 x64 Enterprise and it failed on the .NET Framewok 4.5 package with the error description "Incorrect function". The last lines of the log reads:

     

    [1F78:0714][2011-09-19T08:03:05.973+01:00]: Applying package: netfxfullredist_43, action: Install, path: C:\ProgramData\Package Cache\E3FFCB31565EBEE65CC95C93DB7D11EEE2055D68\packages\dotNetFramework\dotNetFx45_Full_x86_x64.exe, arguments: '"C:\ProgramData\Package Cache\E3FFCB31565EBEE65CC95C93DB7D11EEE2055D68\packages\dotNetFramework\dotNetFx45_Full_x86_x64.exe" /q /norestart /KeepAUPaused /ChainingPackage "" '

    [1F78:0714][2011-09-19T08:03:42.437+01:00]: Error 0x80070001: Process returned error: 0x1

    [1F78:0714][2011-09-19T08:03:42.437+01:00]: Error 0x80070001: Failed to execute EXE package.

    [2184:0860][2011-09-19T08:03:42.437+01:00]: Error 0x80070001: Failed to configure per-machine EXE package.

    [2184:0860][2011-09-19T08:03:43.953+01:00]: MUX:  The reboot behavior for package ( netfxfullredist_43 ) is immediate

    [2184:0860][2011-09-19T08:03:43.953+01:00]: Error 0x80070001: Failed to execute EXE package.

    [2184:0860][2011-09-19T08:03:43.953+01:00]: Error 0x80070001: Failed to execute apply.

    [2184:0860][2011-09-19T08:03:43.957+01:00]: MUX:  Go to Finished page.

    [2184:0860][2011-09-19T08:03:43.961+01:00]: Apply complete, result: 0x80070001 restart: No

    More information about my setup: I mount the ISO using PowerISO. I log in as one user and start the installation as another admin user. 

    Can anyone point me to a solution? I'd love to try this out without having to start Windows 8 every time.

    /Linus

     

    Monday, September 19, 2011 6:31 AM

Answers

  • Hi Linus,

     

    could we try running the dotnetnetfx45_full_x86_x64 setup package alone to see if we get more error info?  Before you do this go to start | run, type in %temp%, delete all the files in the %temp% directory to clean it out.  In the Visual Studio Developer Preview iso, navigate to packages\dotnetframework directory and run the dotnetnetfx45_full_x86_x64 exe as administrator.  if we see the failure, navigate back to the %temp% directory and send the Microsoft .NET Framework 4.5 Developer Preview Setup_<current date>_<somenumber>.html file to mikewongnospam@microsoft.com.  Take out the nospam. 

     

    much appreciated,

    mike

    Microsoft Developer Support

    • Marked as answer by Linus Hamlon Tuesday, September 20, 2011 8:49 AM
    Monday, September 19, 2011 8:19 PM

All replies

  • Hi Linus,

     

    could we try running the dotnetnetfx45_full_x86_x64 setup package alone to see if we get more error info?  Before you do this go to start | run, type in %temp%, delete all the files in the %temp% directory to clean it out.  In the Visual Studio Developer Preview iso, navigate to packages\dotnetframework directory and run the dotnetnetfx45_full_x86_x64 exe as administrator.  if we see the failure, navigate back to the %temp% directory and send the Microsoft .NET Framework 4.5 Developer Preview Setup_<current date>_<somenumber>.html file to mikewongnospam@microsoft.com.  Take out the nospam. 

     

    much appreciated,

    mike

    Microsoft Developer Support

    • Marked as answer by Linus Hamlon Tuesday, September 20, 2011 8:49 AM
    Monday, September 19, 2011 8:19 PM
  • Hi,

    Thanks for your help. I did as you suggested and it worked the second time. It seemed that my failed installation wasn't rolled back properly because after I installed dotnetnetfx45 manually and ran the VS 11 setup I was asked to Repair it or Add/remove features. And the repair failed. But then after an uninstall, reinstall of only the dotnetnetfx45 and lastly an install of the VS 11 it finally worked. :)

    Another point of feedback is that the installation was hogging all the energy from my machine. I could not bare using it while the installation proceeded as my computer was extremely slow. And I'm using a new laptop with i7 and SSD.

    Again, thanks. Looking forward to digging into VS 11 :)

     

     

    • Proposed as answer by chirag_marwaha Sunday, November 27, 2011 6:18 PM
    • Unproposed as answer by chirag_marwaha Sunday, November 27, 2011 6:18 PM
    • Proposed as answer by Ruud van Gaal Tuesday, December 20, 2011 4:30 PM
    Tuesday, September 20, 2011 8:55 AM
  • Hi Mike,

    I have the same issues during installation of VS 11. I got the incorrect function error, i have followed your instruction what you have mentioned above, remove all the flies/folder in temp folder and after this installed the setup successful which is exist in the package folder but still when i repair the installation of VS 11 its gives me the same error. Kindly guide me what should I do for the mitigation of the error.   

    Thanks

    Sunday, September 25, 2011 5:55 PM
  • Hello WaqasYousuf,

     

    do you get the same incorrect function while setup is installing .NET 4.5 or is it on another package at that point?  (check your log file in the %temp% directory)

     

    much appreciated,

    mike

    Tuesday, September 27, 2011 5:57 PM
  • I installed the .net 4.5 full on an admin account

    When I click the vs 11 web install the splash comes up. But then I get an error that says it stopped working. I did clean out the temp dir. there was .tmp files that could not be deleted.

    Friday, September 30, 2011 4:53 PM
  • Same issue more or less here; I tried installing VS2011 on my home Win7/x64; no luck there (packages failing to install). At my office PC it is different, and I'm stuck at dotnextf45*.exe as well, giving an error 'Asia' (yes, that's the message):

    [1AB8:1A44][2011-12-20T15:54:28.029+01:00]: Applying package: netfxfullredist_43, action: Install, path: C:\ProgramData\Package Cache\E3FFCB31565EBEE65CC95C93DB7D11EEE2055D68\packages\dotNetFramework\dotNetFx45_Full_x86_x64.exe, arguments: '"C:\ProgramData\Package Cache\E3FFCB31565EBEE65CC95C93DB7D11EEE2055D68\packages\dotNetFramework\dotNetFx45_Full_x86_x64.exe" /q /norestart /KeepAUPaused /ChainingPackage "" '
    [1AB8:1A44][2011-12-20T15:54:57.840+01:00]: Error 0x800713ec: Process returned error: 0x13ec
    [1AB8:1A44][2011-12-20T15:54:57.840+01:00]: Error 0x800713ec: Failed to execute EXE package.
    [1938:0E4C][2011-12-20T15:54:57.841+01:00]: Error 0x800713ec: Failed to configure per-machine EXE package.
    [1938:0E4C][2011-12-20T15:54:58.018+01:00]: Error 0x800713ec: Failed to execute EXE package.
    [1938:0E4C][2011-12-20T15:54:58.019+01:00]: Error 0x800713ec: Failed to execute apply.

    Tried cleaning %temp%, no luck. Now have uninstalled VS2011, then installed dotnetfx45 by hand, and that works. I'm now installing VS2011 again, see if that gets through.

     

    Tuesday, December 20, 2011 3:16 PM
  • I had the same problem; manually installing dotnetfx45*.exe did the trick. Still, the installer completely forgot about the directory I entered, and installed 99% in C: anyway (much like a lot of apps that fail to install to where you point them).

    It's running now; I have an idea why it wouldn't install on my home PC; I didn't have 6Gb of free space there on my system HD (I never install things on C:, but even with 70Gb I run out of disk space; most apps just ignore the fact that you're not installing to C:, but that's a different story).

    Now finally after 2 days of installation woes to try to compile something. ;-)

    Edit: got my project to compile, solution conversion (from VS2008) went without too much trouble. Compiling only required a _WIN32_WINNT=0x501 somewhere.

    Running is a different matter; an inline function such as:

      void   Normalize()
      {
        float l=LengthSquared();
        if(l<D3_EPSILON)
        {
          // Don't leave a zero vector
          x=z=0;
          y=1.0f;
        } else
        {
          float scale=1.0f/sqrtf(l);
          x*=scale;
          y*=scale;
          z*=scale;
        }
      }

    turned out to generate incorrect values (normalizing (0.999749,0.000064,-0.004496) to (1.874921,0.000120,-0.008431)). When outlining this function, I still had problems, and as it already took me several hours to figure out that Normalize() generated bad code I'm giving up there.

    Also, trying to set any debug options (working Directory or Program Arguments) it only reverts to the originals everything I click 'Apply', so I can't really go into Debug mode.

    So much for going directly from a VS2008 project to VS2011. I might try to restart the solutions from scratch, that is known to be a lot more robust (I've learned with previous compiler switches; VC6->VS2005, VS2005->VS2008)...

    Edit2: Several hours later I abandoned the converted solutions and created them from scratch. First impressions look better, apart from some problems when adding an existing project to a solution gave 'Access denied', and I had to use a different directory (it was named 'lib').

    Edit3: one problem still remained. When trying to fix that I noticed that /LTCG was turned on and gave very long link times (generating code). I turned that off in the linker and the projects (turning off 'Whole Program Optimization'). That gave back the problem in #1. The optimizer seems too buggy still. Might try VS2011 again in 6 months or so, hopefully the optimizer is less buggy then.

    Tuesday, December 20, 2011 4:30 PM
  • I have the same issue and i have downloaded the ISO 4 times already and i have the same issue I think, error message says:

     

    Microsoft Visual C++ 11 Compilers   Signature was no present on the Subject.

     

    Any ideas?

    Thursday, January 12, 2012 2:15 AM
  • I had the same problem as the OP.  DotNet4.5 failed to install correctly.

    I followed Mikes instructions and got it working... I had to manually install the dotnetfx45 package from the .iso then repair the installation.  After a couple of reboots it worked fine.

    When I installed the dotnetfx45 package, I noticed it requested stopping Windows Backup and another service, which I accepted.

    Monday, March 5, 2012 3:28 AM