Azure file sync files fail to recall files RRS feed

  • Question

  • I have setup Azure file sync for some file server archive files (approx 600GB).

    On initial setup eveything worked as expected. The files are in Azure and could be accessed by the on-prem server (server 2012 R2) with the agent installed and cloud endpoint created.

    However, I can no longer recall files using the on-prem server.

    I can connect directly to the Azure share using SMB and everything is there and accessible. the files on the on-prem server have a grey cross of them. when I attempt to open the files, for example an word doc, I get an error when Word tried to open the file saying could not open.

    Agent version was running Refresh 2 but I updated to 3.0.13 yesterday to try and resolve, no luck.

    yesterday cloud tiering was enabled at 40% which I disabled to see if that would force all files to be on the server. no change.

    I have followed the troubleshooting on https://docs.microsoft.com/en-us/azure/storage/files/storage-sync-files-troubleshoot.

    StorageSync.sys and StorageSyncGuard.sys are present and there are no errors or anything obvious in event viewer. the file sync service is running.

    rebooted the server. a lot of files still have the fgrey cross and cannot be opened.

    A bit stuck as to what to do now. I know this is still in preview but anyone have any ideas's.
    I have run the AFSdiag tool as suggested.

    Wednesday, July 4, 2018 8:49 AM

All replies

  • Could you check the attribute on the file? Just confirm the status of attribute with suggested document below.

    You also can use PowerShell to force a file to be recalled. This option might be useful if you want to recall multiple files at once, such as all the files in a folder. Open a PowerShell session to the server node where Azure File Sync is installed, and then run the following PowerShell commands.

    Import-Module "C:\Program Files\Azure\StorageSyncAgent\StorageSync.Management.ServerCmdlets.dll"
    Invoke-StorageSyncFileRecall -Path <file-or-directory-to-be-recalled>

    Refer: https://docs.microsoft.com/en-us/azure/storage/files/storage-files-faq

    Wednesday, July 4, 2018 3:19 PM
  • On the server the file attributes for these files are APLO

    I have tried running the powershell as suggested on multiple files, I get the PS error:

    WARNING: Some files failed to be recalled. Please see FileSyncSvc event channels for more information.

    Event log:

    Log Name:      Microsoft-FileSync-Agent/Operational
    Source:        Microsoft-FileSync-Agent
    Date:          04/07/2018 16:26:52
    Event ID:      9109
    Task Category: None
    Level:         Warning
    User:          SYSTEM
    Computer:      SERVER.DOMAIN.NAME
    Recall failed for file:\\?\LOCATION TO FILE, ErrorCode:-2147024895, HRESULT:0x80070001 - Incorrect function.

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
        <Provider Name="Microsoft-FileSync-Agent" Guid="{4E816BB7-D169-59A8-A02D-3892859A3B96}" />
        <TimeCreated SystemTime="2018-07-04T15:26:52.209062000Z" />
        <Correlation />
        <Execution ProcessID="1220" ThreadID="4464" />
        <Security UserID="S-1-5-18" />
        <Data Name="FilePath">\\?\file:\\?\LOCATION TO FILE</Data>
        <Data Name="ErrorCode">-2147024895</Data>
        <Data Name="HResultStr">0x80070001 - Incorrect function.

    Wednesday, July 4, 2018 3:33 PM
  • The error usually comes when the service is unable to communicate with the filter.

    Can you get the output of "fltmc instances" from an administrator command prompt? This will show if the filter StorageSync and storagesyncguard filters are loaded. 

    If the filter is not viewable in the output check for the files c:\windows\system32\drivers\StorageSync.sys and c:\windows\system32\drivers\Storagesyncguard.sys

    Also it could be interop issue if any Anti virus is installed.


    Wednesday, July 4, 2018 7:54 PM
  • running the instances command I can only see storagesyncguard:

    Filter                Volume Name                              Altitude        Instance Name       Frame   SprtFtrs  VlS
    --------------------  -------------------------------------  ------------  ----------------------  -----   --------  ---
    StorageSyncGuard      E:                                        180465     StorageSyncGuard          0     00000000
    StorageSyncGuard                                                180465     StorageSyncGuard          0     00000000
    luafv                 C:                                        135000     luafv                     0     00000003
    npsvctrig             \Device\NamedPipe                          46000     npsvctrig                 0     00000000

    In drivers dir I have:

    Thursday, July 5, 2018 7:43 AM
  • The StorageSync driver is not loaded and is required to access files that are tiered.

    Run the following command from an elevated command prompt:

    fltmc load storagesync

    On the same elevated command prompt, run the command "fltmc" and confirm "StorageSync" filter driver is loaded.

    Once you confirm the filter driver is loaded, try to access a file that was previously failing.

    If manually loading the driver works, we need to identify why the driver is failing to load automatically. Please run AFSDiag (see instructions in the Troubleshooting guide) and send the output to jeffpatt at microsoft dot com.

    Thursday, July 5, 2018 4:58 PM
  • I ran the command and the output was:

    PS C:\Program Files\Azure\StorageSyncAgent> fltmc load storagesync

    Load failed with error: 0x80070002
    The system cannot find the file specified.

    I have sent the AFSDiag output to you

    Friday, July 6, 2018 8:29 AM
  • Please try the following steps on the server experiencing the issue:

    1. Go to <Agent install directory>\Filter directory.
    2. Right click on "StorageSync.inf" and select Install. The action runs elevated and will install the filter driver.
    3. Verify StorageSync.sys exists in the C:\Windows\System32\Drivers directory.
    4. On an elevated command prompt run the command "fltmc load storagesync". This will load the "StorageSync" tiering filter
    5. On the same elevated command prompt run the command "fltmc" and confirm the "StorageSync" tiering filter is loaded now.
    Friday, July 6, 2018 6:07 PM
  • This issue was resolved by uninstalling and reinstalling the agent.
    Wednesday, July 11, 2018 4:20 AM