locked
Unknown Windows API Function Error - Windows 8 Developer Preview - Call of Duty 4 - EvenBalance Services

    General discussion

  • This is a good fix to look at for those new games releasing soon an for the public to enjoy there games both SP/MP without any problems from just coming home from a hard days work an relaxing on just hopping onto the PC an joining there favorite servers on there favorite games without any issues. Its the connection trying to be stable from the OS to the server to EvenBalance services, "pbsvc.exe" installed the PunkBuster services successfully with no error but the functionality between stability of how strict the PB settings may be on the server it then kicks you giving you this error in the picture I have provided.. There are more problems an fixes that I'm currently looking at an getting around to improve an will be frequently coming back an forth to the questionnaire on my questions/awnsers, if this problem could be looked at an fixed in the next coming updates that will be rolling in that would be awesome as i'm also a big gamer an love my Call of Duty 4 battles online (:

    Cheers,
    Stevie-Ray Lightband

    *Is there anything in for all the people that are helping out Microsoft with developing the outcome of Windows 8 once it becomes Retail after all the issues being fixed an becoming fully stable as Windows 7 is?
    Friday, November 04, 2011 12:56 AM

All replies

  • Sorry about making this a question where it should have been posted as a new discussion... Lol I only just noticed the tick box as I hit "Send" that there was "Start a Discussion" :/


    Friday, November 04, 2011 12:58 AM
  • Note that this pre-Beta version and these issues are expected, try run call of duty in compatibility mode by right click and run compatiblity.
    Friday, November 04, 2011 11:02 AM
  • Note that this pre-Beta version and these issues are expected, try run call of duty in compatibility mode by right click and run compatiblity.


    Will try that one out mate, cheers.

    Also I'm looking at another problem at this very moment "explorer.exe - Metro Styled" it was worked fine every restart/shutting down an starting up the PC, BUT.. Once any GPU video driver is installed for PCI-E functionality for smoother motion "v-sync" an compatibility for the games to be running BUT.. All the games have to be run in Administrative mode otherwise you get the Hard drive is too full error if so which is alright for the time being until further updates (:.. Just the main thing annoying me atm is "explorer.exe" I run a EVGA GeForce GTX580 Superclocked x4, they all run perfectly fine in SLi mode an the driver 280.something (just the latest one that came out from beta recently) AN "explorer.exe" was alright an i was having the nVidia control panel icon on the explorer tray, but now when I start up my PC it suspends itself on an off an glitches out an once I have it right after going into task manager an end tasking the multiple "explorer.exe's" I then don't have the icon in the tray anymore... It doesn't interfere with gaming though that is perfectly fine (: just explorer.exe isn't stable with the new video settings/driver it keeps starting up an up again after again causing multiple tasks mm, like its trying to detect the display.


    Cheers, Stevie-Ray Lightband
    Saturday, November 05, 2011 12:14 AM
  • Have already attempted several ways to fix this issue Stevie, however, at the moment none have appeared to work. I have run the install in compatibility mode, the COD exe in compatibility mode, as well as pbuster in compatibility mode, still getting the same kicks, for bad drivers, or bad win api function calls. I am going to debug the error and see where it's cropping up and see if I can't get it resolved.

     

    Wednesday, February 01, 2012 3:41 AM