locked
Problem with app: approved, but crashes. RRS feed

  • Question

  • I have made an app  (WP7.1) that uses streaming audio, it was approved after 2 rejections. However when downloaded and installed the app just crashes (on lumia820/WP8: chrashes instantly) or doesn't work (lumia800/WP7, it loads and the buttons/pages work, except for the playbutton where clicks are ignored.)

    So basically I need to debug an error, but i have some problems reproducing it:

    The app works on my dev-machine and phones, it works (hopefully) when MS is testing it, but when I and the users download it it doesn't work (thats what they write in the reviews at least).

    I have tried to submit the same app as a beta app, I can download it but it does not install using the app-deploy tool.

    We have removed the app from the store since it didn't work, but the beta is here:

    http://www.windowsphone.com/en-us/store/app/radio-abc/42b861a3-fb6a-49c0-8731-ee1f1730d218?appid=42b861a3-fb6a-49c0-8731-ee1f1730d218

    Is there any way to get the beta to install and run?

    Is there something else I can try, to get around the submission wait period (i.e. test without going through the MS-approval process) and get an app where i can replicate the errors?

    There might be some more info in these 2 stackoverflow posts:

    Problem:

    http://stackoverflow.com/questions/16309748/app-approved-but-crashes

    Trying to work around it:

    http://stackoverflow.com/questions/16332408/windows-phone-download-xap-before-publish-possible

    Thanks in advance :)


    Coolsystems

    Monday, May 6, 2013 7:28 AM

All replies

  • It could be that you left a call to "LaunchForTest" in your code.

    Or one of the capabilities that you require was stripped from the WMAppManifest.xml because a reference was not found in your base assembly.

    For the second part, unzip the signed XAP file that you downloaded and review what capabilities are in the WMAppManifest.xml.


    -Eric.

    Monday, May 6, 2013 10:29 PM