locked
SharePoint Upload limit and upload process RRS feed

  • Question

  • We have set the SharePoint upload limit to 100Mb. Sometimes when we upload 73MB doc, it uploads successfully.

    Sometimes with the same limit, 73MB fails with

    "The form submission cannot be processed because it exceeded the maximum
    length allowed by the Web administrator. Please resubmit the form with less
    data."

    When i now change the limit to 150MB, it still fails with same error. Then when I increase the limit to 200Mb, the file uploads succssfully.

    These are happening at different times of the day.

    For all this process I use single file upload page.

    The same happens for multiple file upload page, but only it doesn't throw the error above, rather it show "Failed" immediately.

    Is the upload limit is a concurrent upload limit? That means, let say the limit is 100Mb, and I am uploading 70Mb file and somewhere in my company at same time someone is uploading 50MB file, this means now the current upload size is 120MB, therefore one of the upload fails?

    Wednesday, January 16, 2013 6:27 AM

Answers

  • Hi Hemendra,

    Yes that setting is done.

    We have:
    <httpRuntime maxRequestLength="1524000" executionTimeout="999999" />

    We also have:
       <security>
          <requestFiltering>
            <requestLimits maxAllowedContentLength="4262428800" />
          </requestFiltering>
        </security>

    A lot? Yes we have it for some auto upload process

    Anyways... the upload is working, and the setting is fixed and limit is fixed. The question is why yesterday I cannot upload 93MB file with 100Mb limit, but today I can upload 93MB file successfully with 100MB limit? What could be different?

    Wednesday, January 16, 2013 9:04 AM

All replies

  • Hi,

    Did you set maxRequestLength in web.config file? if not then do this as well.

    <httpruntime maxrequestlength="102400" executiontimeout="3600"></httpruntime>
    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Wednesday, January 16, 2013 6:41 AM
    Moderator
  • Hi Hemendra,

    Yes that setting is done.

    We have:
    <httpRuntime maxRequestLength="1524000" executionTimeout="999999" />

    We also have:
       <security>
          <requestFiltering>
            <requestLimits maxAllowedContentLength="4262428800" />
          </requestFiltering>
        </security>

    A lot? Yes we have it for some auto upload process

    Anyways... the upload is working, and the setting is fixed and limit is fixed. The question is why yesterday I cannot upload 93MB file with 100Mb limit, but today I can upload 93MB file successfully with 100MB limit? What could be different?

    Wednesday, January 16, 2013 9:04 AM
  • Hi,

    >he question is why yesterday I cannot upload 93MB file with 100Mb

    When did you set above settings? If you did it today then it was the cause if you had already then there might be problem network or may any other. Can not tell you exact problem until don't see the log or any other clue.

    Anyway if you problem is resolved (as you said) so can we close this thread?


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Wednesday, January 16, 2013 9:11 AM
    Moderator
  • Thanks Hemendra,

    Yes it is solved. Just want to know about the uploading process and if the upload process is bound by the number of concurrent upload or not.

    Wednesday, January 16, 2013 10:36 AM
  • >if the upload process is bound by the number of concurrent upload or not.

    No. If there are multiple users at a time and file size is big then you may encounter with slowness otherwise rest is fine.


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Wednesday, January 16, 2013 10:40 AM
    Moderator
  • Thanks Hemendra. Appreciate the answer. This thread can be closed.
    Wednesday, January 16, 2013 10:52 AM