locked
Can't configure continuous delivery with VSTS - getting error in portal RRS feed

  • Question

  • When I click on any one of my three web apps and open the Continuous Delivery blade, then click to configure repository, all my settings are pre-populated with the correct VSTS repository and branch, which is linked to the same MS account. 

    However, the OK button is always greyed out and I begin getting a bunch of portal errors, one every couple seconds (text and screenshot below).

    What could be the issue?


    Experiencing authentication issues

    The portal is having issues getting authentication tokens for AzureTfsExtension.

    Tuesday, December 26, 2017 4:30 AM

All replies

  • App Service Authentication/Authorization is exposed in the Azure Preview Management Portal. To enable it, navigate the Settings blade of any Web or Mobile App and select Authentication/Authorization. Flip the switch to On to view the options for protecting your site.

    For more information, kindly refer the link given below:

    https://azure.microsoft.com/en-us/documentation/articles/app-service-api-dotnet-user-principal-auth/

    Hope this helps.

    Tuesday, December 26, 2017 4:39 AM
  • This did not help.
    Tuesday, December 26, 2017 5:08 AM
  • Hi, anyone who can assist with this issue?
    Wednesday, December 27, 2017 3:47 AM
  • I would suggest you open “Developer Tools” by pressing f12 or CTRL+SHFT+I, look at the network traces and then see which calls are failing and save the responses for the calls that are failing. This will contain a correlation id which would help us in finding the traces in our product traces.

    ------------------------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Wednesday, January 3, 2018 9:23 AM
  • I went to the Team Services section in the Azure Portal and "connected" the VSTS account. After doing so, I can no longer login at "myappname.visualstudio.com". I get the following error:

    Additional technical information:
    Correlation ID: 4c456c38-ea34-46a6-a2df-28c2f61b45eb
    Timestamp: 2018-01-21 22:52:29Z
    AADSTS70001: Application '499b84ac-1321-427f-aa17-267ca6975798' is disabled.

    Sunday, January 21, 2018 10:54 PM