locked
unable to connect to the configured development Web server (VS express 2013 for web RRS feed

  • Question

  • User-544603474 posted

    A few months ago I installed VS Express 2013 for Web on a PC with windows 7 SP1. Everything worked fine. But a few weeks ago it was suddenly impossible to run a website. I received the error "unable to connect to the development webserver". Between the time of installation of the VS for web and the appearance of the problem I installed webmatrix3. I uninstalled the webmatrix, SQL server 2012, VS for windows desktop, re-installed VS for web, but the problem was not solved. I executed VS for web as administrator, specified a fixed port for the localhost to run, give the port all necessary access, but the problem is still not solved. I re-installed webmatrix3, but the problem is still not soved.

    I performed a reset of the VS settings and a repair of the installation. I received no errors, but the problem is still not solved.

    I tried to run the application in safe mode, but did not succeed. The application did not want to start running and gave no errors.

    Can someone help me to fix this problem?

    Ann

    Tuesday, June 2, 2015 2:19 PM

Answers

  • User-166373564 posted

    Hi Ann,

    I uninstalled the webmatrix, SQL server 2012, VS for windows desktop, re-installed VS for web, but the problem was not solved.

    Visual Studio lets you test with different web servers, including IIS Express, Internet Information Services (IIS), External Hosts, or Custom Web Servers. You can use any of these web servers with a file-based web application project. follow this guide to reset it in VS, and check whether it can fix it.

    See: https://msdn.microsoft.com/en-us/library/58wxa9w5.aspx 

    Please let me know if there is anything that I can do to help.

    With regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 5, 2015 6:17 AM
  • User-166373564 posted

    Hi Ann,

    Thanks for your feedback.

    You can also follow steps below:

    To specify the Web server for a Web site project

    1. In Solution Explorer, right-click the name of the Web site project for which you want to specify a Web server, and then click Property Pages.

    2. In the Property Pages dialog box, click the Start Options tab.

    3. Under Server, click Use custom server.

    4. In the Base URL box, type the URL that Visual Studio should start when running the current project.

    With regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 22, 2015 1:30 AM

All replies

  • User-166373564 posted

    Hi Ann,

    I uninstalled the webmatrix, SQL server 2012, VS for windows desktop, re-installed VS for web, but the problem was not solved.

    Visual Studio lets you test with different web servers, including IIS Express, Internet Information Services (IIS), External Hosts, or Custom Web Servers. You can use any of these web servers with a file-based web application project. follow this guide to reset it in VS, and check whether it can fix it.

    See: https://msdn.microsoft.com/en-us/library/58wxa9w5.aspx 

    Please let me know if there is anything that I can do to help.

    With regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 5, 2015 6:17 AM
  • User-544603474 posted

    Hello Angie

    Thank you for your reply!

    On the website property pages - start options I tried for the custom web server http://localhost:50101/, without success! Normally I work wit IIS Express 8.0. When I re-installed it the map IISExpress in my documents was not re-created. When you open the files in the map IISExpress lots of things seemed to be wrong. I tried to fix it with help of the web, but everything got worse. Finally  I copied the map from the laptop of my son, the extra problems disappeared, but the basic problem is still there.

    I can not think about anything else that I could do.

    regards

    Ann Gillis

    Saturday, June 6, 2015 7:02 AM
  • User-166373564 posted

    Hello Ann,

    Thanks for your feedback.

    On the website property pages - start options I tried for the custom web server http://localhost:50101/, without success! Normally I work wit IIS Express 8.0. When I re-installed it the map IISExpress in my documents was not re-created. When you open the files in the map IISExpress lots of things seemed to be wrong. I tried to fix it with help of the web, but everything got worse. Finally  I copied the map from the laptop of my son, the extra problems disappeared, but the basic problem is still there.

    Visual Studio 2013 allows developers to add custom web servers to their projects, as the link mentioned in my previous post, could you check the procedure of Visual Studio 2013 Custom Web Servers and OwinHost.exe 

    With regards,

    Angie

    Monday, June 8, 2015 10:49 PM
  • User-544603474 posted

    Hello Angie

    Thanks for your help!

    I installed the NuGet Package Microsoft.Owin.Host.SystemWeb.

    In the property pages of the website I can not select the Owin server. There is no dropdownlist. Maybe this is the case because I work with the Express version.

    I also took a look at packages.config file. It contains 3 packages concerned Owin, but specifies the "Packages"-element is not declared.  It is underlined in blue.

    Do you have any suggestions to solve the problem?

    regards

    Ann Gillis

    Wednesday, June 10, 2015 10:47 AM
  • User-166373564 posted

    Hi Ann,

    Thanks for your feedback.

    You can also follow steps below:

    To specify the Web server for a Web site project

    1. In Solution Explorer, right-click the name of the Web site project for which you want to specify a Web server, and then click Property Pages.

    2. In the Property Pages dialog box, click the Start Options tab.

    3. Under Server, click Use custom server.

    4. In the Base URL box, type the URL that Visual Studio should start when running the current project.

    With regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 22, 2015 1:30 AM
  • User2053451246 posted

    Do you have special identity settings set up in your application pool in IIS?  Has your domain password changed and you haven't changed it in IIS?

    Monday, June 22, 2015 11:31 PM
  • User-544603474 posted

    Angie

    This was one of the first things I tried without success. 

    Thanks for your replies!

    regards

    Ann

    Friday, August 7, 2015 5:10 AM