none
VBA editor problem with the "Single Quote" and "Double Quote" RRS feed

  • General discussion

  • Bruce Song,

    Windows 7 32-bit, Access 2010 32-bit.

    Just today I discover a problem with the VBA editor. Although it might not be related to intellisense, it was interesting anyway.

    I discovered a problem with the "Single Quote" and "Double Quote".

    While typing the quotes, I notice that the character did not appear on the Editor.

    1. If I key again, two quotes appeared.
    2. If I key in a character say "e", it appear as a ë in German I think.
    3. If I key a space, the quote will appear.

    It's annoying but nevertheless I hope you can tell them about it too.

    Something is messing up VBA editor. I will check was there any Access Service Pack 1 updates done on this User at a later time.

    • Edited by AccessVandal Tuesday, October 4, 2011 10:04 AM
    • Split by Bruce Song Wednesday, October 5, 2011 8:44 AM new problem
    Tuesday, October 4, 2011 10:01 AM

All replies

  • Bruce Song,

    Windows 7 32-bit, Access 2010 32-bit.

    Just today I discover a problem with the VBA editor. Although it might not be related to intellisense, it was interesting anyway.

    I discovered a problem with the "Single Quote" and "Double Quote".

    While typing the quotes, I notice that the character did not appear on the Editor.

    1. If I key again, two quotes appeared.
    2. If I key in a character say "e", it appear as a ë in German I think.
    3. If I key a space, the quote will appear.

    It's annoying but nevertheless I hope you can tell them about it too.

    Something is messing up VBA editor. I will check was there any Access Service Pack 1 updates done on this User at a later time.

    Hi AccessVandal,

    This has nothing to do with a bug.
    It is just the kind of keyboard that you use. What you describe is my favourite Dutch keyboard.
    If you change your keyboard back to American, all will be normal for you again.

     

    Imb.

    Tuesday, October 4, 2011 10:09 AM
  • Hi,

    THAT is a problem with Windows: I know what your problem is, but I cannot find again where I have to change what!

     

    Imb.

    Tuesday, October 4, 2011 10:20 AM
  • It's the default US keyboard setting. No language settings even, it only US.
    Wednesday, October 5, 2011 1:41 AM
  • Hi AccessVandal,

    Can you show me the reproducible step list? Because I couldn't reproduce the scenario you described on my side. It will be nice if you can show me some screenshots.

    I will try to reproduce it on my side.

    Best Regards,


    Bruce Song [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, October 5, 2011 3:20 AM
  • Bruce,

    There wasn't any setup. Just simply key into the editor. The user just upgrade his PC with Office 2010 from 2007. I was editing his older version of 2007 accdb database. But as I re-called, there wasn't any special language setting even in 2007. Everything was installed by default.

    Anyway, is there any special in the VBA editor that might cause this?

    I am going back this week to re-do his new requirement of the database and will update if there's anything.

    Wednesday, October 5, 2011 6:19 AM
  • @Bruce Song, can you somehow farm these irrelevant replies out into a separate thread? They're well off-topic.

    Did you submit the original issue to the folks who can fix it?


    Matthew Slyman M.A. (Camb.)
    Wednesday, October 5, 2011 7:14 AM
  • It's the default US keyboard setting. No language settings even, it only US.


    Hi AccessVandal,

    On WindowsXP I figured it out a little bit.

    When I type in VBA repeatedly the e and single quote, then I get "ééééé" when NL was selected, and "e'e'e'e'e'" when EN was selected.

    Configuration screen > Countries > Languages > Details.

     

    @Matthew: excuses for this off-your-topic comment.

     

    Imb.

    Wednesday, October 5, 2011 8:23 AM
  • Hi Matthew,

    Have helped you submit it to CFA. If there is any update, I will notify you.

    Best Regards,


    Bruce Song [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, October 5, 2011 9:49 AM
  • Ok, I'm back from the user end.

    There is nothing wrong with the regional setting and language (default US) on the Win7 but forgot to check about SP1(unlikely to be updated). Access 2010 is without SP1.

    Tried the Access Option - language (English US)....still no luck.

    My initial guess was that it might be due the VBA intellisense messing up but I could be wrong. The fact that it looks like intellisense was waiting for user input after keying in the quote make's me wonder.

    I could do a re-install of Office 2010 again but I 'll leave it as it is as the user does not use VBA as part of his work. And as it does not affect me, I'll leave it as it is.


    Friday, October 7, 2011 9:33 AM