none
HTTP Receive - BTSHTTPReceive.dll 500 Error RRS feed

  • Question

  • Hi All

    I couldnt figure out anything from the similar posts in these forums on 500 Error

    But ,below is the error when i try to browse the url of an IIS 7 app on win 2008 R2

    Module IsapiModule

    Notification ExecuteRequestHandler

    Handler ISAPI-dll

    Error Code 0x00000000

    I have script map added for BTSHTTPReceive.dll on the root and an app pool configured to Enable32bitApplications

    The virtual directory is configured to C:\Program Files (x86)\Microsoft BizTalk Server 2010\HttpReceive\BTSHTTPReceive.dll

    Everything was working before the following was run on command prompt accidentally

    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 0
    C:\WINDOWS\Microsoft.NET\Framework64\vX.X.XXXXX>aspnet_regiis.exe -i

    But later I have reverted it back with the following

    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1
    C:\WINDOWS\Microsoft.NET\Framework\vX.X.XXXXX>aspnet_regiis.exe -i

    Additional details from the trace says just warning as below

    ModuleNameIsapiModule

    Notification128

    HttpStatus500

    HttpReasonInternal Server Error

    HttpSubStatus0

    ErrorCode0

    ConfigExceptionInfo

    Notification EXECUTE_REQUEST_HANDLER

    ErrorCode The operation completed successfully. (0x0)

    Any thoughts on this pls.Thanks


    http://biztalkguide.blogspot.com/ Please mark as answer if this solved the issue.Thanks


    • Edited by amsullu Thursday, February 16, 2012 11:38 AM additional info
    Thursday, February 16, 2012 10:47 AM

Answers

  • This issue is now resolved.

    There was an HTTP Handler for Isapimodule ,*.dll enabled. Removing this , solved the issue with BTSHTTPReceive.dll

    HTH.

    Sullu


    http://biztalkguide.blogspot.com/ Please mark as answer if this solved the issue.Thanks

    • Marked as answer by amsullu Thursday, February 16, 2012 2:30 PM
    Thursday, February 16, 2012 2:30 PM